Jump to content

NVIDIA P40 on Ubuntu VM


Go to solution Solved by Subcode,

Recommended Posts

Hi,

Im trying to get a NVIDIA P40 working on a ubuntu VM using the passthrough. I want to use run some AI projects etc. But no matter what i do, no matter which driver i install or how i install it i always get the message: nvidia-smi cannot communicate with the driver. I tried installing the driver through apt, through ubuntu-drivers, and throught the .run file from the nvidia website.

The card does show up in cpu-x as a nvidia p40. But it always says: no driver.

 

I then tried installing a windows 10 vm out of desperation. And now the P40 takes priority over the virtual graphics card and i get: guest has not initialized the display yet. Even though the P40 has no video out ports. So i cant attach a screen to it either.

Its driving me insane cause i have 30 days to verify the card even works before having to send it back... (ebay purchase). And i cant even get to a point where i can say its the driver that doesnt work or the card.

 

Can anyone tell me how to get that P40 to work in Ubuntu? Its where i intend to end up using it.

I've seen a lot of comments in random threads about P40s and ive tried to make sence of it but i really cant make hear or tails of it.

Link to comment
  • Solution
On 1/31/2023 at 2:05 AM, KptnKMan said:

Looks like I figured it out, I had left out the steps to add the extra lines to my Win11 VM, which enabled 64GB ReBAR support.

 

So looks like the checklist to enable this:

- Host BIOS Enable ReBAR support

- Host BIOS Enable 4G Decoding

- Enable & Boot Custom Kernel syslinux configuration (near beginning of this thread)

- Boot Unraid in UEFI Mode

- VM must use UEFI BIOS

- VM must have the top line of XML from <domain type='kvm'> to:

<domain type='kvm' xmlns:qemu='http://libvirt.org/schemas/domain/qemu/1.0'>

- VM must have added the following (after the </device> line, before the </domain> line):

  <qemu:commandline>
    <qemu:arg value='-fw_cfg'/>
    <qemu:arg value='opt/ovmf/X-PciMmio64Mb,string=65536'/>
  </qemu:commandline>

 

After that, looks like everything worked for me as well.

I'm just summarising this for anyone looking for a complete idea.
 

I'll be testing performance over the next weeks as well to see if I'm seeing any improvement.

 

This is great, exactly what I've been waiting for!

  • Thanks 1
Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...