Jump to content

Yet, another slow network transfer post


Go to solution Solved by russo,

Recommended Posts

Ok, i've been troubleshooting this for the past 2-3 days and Im now at my whitts end. Im summoning your help.

 

Backstory:

for the past 2-3 years I've been running (2) Truenas servers.  One was a backup and the other is (still is) my main media sever.

 

What I need to do is transfer all of my content (~50TB) from my main Truenas server over to my new Unraid.

When i did transfers in the past between my 2 Truenas servers, I would get 80-90MB/s (almost hitting my 1 gig max.) My method of transfer between the servers has always been SFTP over ssh via Flashfxp. However, when i try to transfer from my Truenas to my Unraid, I can not achieve more than 21-22MB/s (usually much lower)

 

 

Things I have tried:

 

*allowed my data to pass through my cache drive first.

 

*activate turbo write

 

*checked and double check my cables connected to this server (all of CAT5e or 6) - NO CAT5 in system-

 

*Started out using the onboard Realtek 1gig nic, swapped out to 

  Intel Gigabit CT PCI-E Network Adapter EXPI9301CTBLK, then swapped out to a 

  Broadcom NetXtreme 10/100/1000Mbps BCM5751 NIC Nic

(As you can see, no improvement with the 3  different cards.

 

*Iperf3 test from the Truenas sever to the Unraid seems to check out "OK"

https://imgur.com/qmQ4SPw

 

*ethtool seems to show no issues:

Quote

Settings for eth0:
    Supported ports: [ TP ]
    Supported link modes:   10baseT/Half 10baseT/Full
                            100baseT/Half 100baseT/Full
                            1000baseT/Full
    Supported pause frame use: No
    Supports auto-negotiation: Yes
    Supported FEC modes: Not reported
    Advertised link modes:  10baseT/Half 10baseT/Full
                            100baseT/Half 100baseT/Full
                            1000baseT/Full
    Advertised pause frame use: No
    Advertised auto-negotiation: Yes
    Advertised FEC modes: Not reported
    Speed: 1000Mb/s
    Duplex: Full
    Auto-negotiation: on
    Port: Twisted Pair
    PHYAD: 1
    Transceiver: internal
    MDI-X: off (auto)
    Supports Wake-on: pumbg
    Wake-on: g
        Current message level: 0x00000007 (7)
                               drv probe link
    Link detected: yes

 

Now for desperate times:

* removed ALL hard disc drives from the unraid sytem except for (1) 16 TB drive.  No improvement with this. Transfer rates still bad. There doesnt seem be to a bottle neck.

 

attached are my diagnostics.

 

Anything thing else I should try?

 

 

 

 

tower-diagnostics-20230529-2016.zip

Edited by russo
Link to comment

No compression that I know of.

 

However, now we are making progress!!!!!!

 

Here are my SMB transfers.

 

Untitled.jpg.7fda6d125e61f77fcbe2b9d96bf62745.jpg

 

 

I actually was averaging about 85-93MB/s on this transfer (below)

untitled2.jpg.0d9aa45ef729da6d5368ce09d4ce2714.jpg

 

 

untitled3.jpg.1406d59b0a34f293b4843df163abf1c6.jpg

 

 

So what does this tell us? I mean, we are practically getting 1 gig transfers via SMB in all directions?  Just  a reminder, when I did SFTP transfers from

TRUENAS ---->TRUENAS (BACKUP) I would generally saturate my network connection. I cant do this with TRUENAS to UNRAID.

 

 

thanks for helping me.

Link to comment

Try transferring from TrueNAS to Unraid using rsync over SSH, make sure no compression is used with rsync (-x), for example, from the Unraid side:

 

rsync -av root@TrueNAS_IP:/mnt/pool/dataset/ /mnt/user/share/

 

if you get permission errors, which is normal with TrueNAS and rsync add --no-perms to the command.

Link to comment
  • Solution

Ok, Rsync shows that im hitting the 1gig transfer rate.  Im going to guess that there's a setting somewhere within my FLashFXP client that is causing the slow down.  I didnt experience this slowdown when i transferred between the 2 Truenas servers.

I think i'll use this Rsync for now on since it consistently hits over 100MB/s

 

Dont judge me by my file names 🤪

 

again, a big thank you to YOU :)

 

untitled4.thumb.jpg.610b113818f1d63b3b0f92461821bac4.jpg

 

 

 

 

  • Like 1
Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...