Jump to content

Apple TimeMachine not functioning


Recommended Posts

I have been using my UnRaid Server to host TimeMachine (TM) backups for a number of years now. However around the time of updating to 6.11.x I seem to be plagued with issues around TimeMachine. I have tried troubleshooting this to the best of my ability but I seem to be stuck at the moment. I keep getting errors; most recently on my Mac an error (112) that seems to indicate that the disk either disconnected or that for whatever reason TM doesn't have the access/permissions to the disk that it needs. And therefore don't complete any further backups past the first one. I seem to be able to set up an initial TM backup but I can't seem to get it to do the incremental backups. Of the things I have tried over the past year or so to fix this are the following:

1. Completely deleting the share and creating a new backup share and starting completely from scratch. Both Public and Private permissions on the share, and making sure TM is selected in the SMB options. 

2. Tried re-writing permissions to the time machine share (but may have failed at doing it), from both Unraid console and MacOS Terminal

3. Tried verifying backup on MacOS

4. Tried following SpaceInvaders guide on migrating TM backup to 6.11.x 

 

All of this has been unsuccessful. I am still having persistent issues backing-up my Mac to my server. So I am hoping I can find some help here. Thanks in advance for your assistance it is greatly appreciated. 

treadstone51-diagnostics-20230616-0722.zip

Screen Shot 2023-06-16 at 07.24.27.png

Edited by Falcowe
Added Screenshot of the TM error
Link to comment

Disclaimer:  I am not a Apple user!!!

 

Start here:

 

    https://forums.unraid.net/bug-reports/prereleases/macos-optimization-r2087/

 

And there is a support sub-forum for MacOS-SMB problems that you can find here:

 

     https://forums.unraid.net/forum/103-macossmb/

 

And finally in the Documentation, there are these sections:

 

     https://docs.unraid.net/unraid-os/guides/configuring-time-machine#creating-multiple-time-machine-shares-for-different-peoplemacs

and

     https://docs.unraid.net/unraid-os/guides/configuring-time-machine#unraid-and-time-machine-setup

 

Hope this helps....

Link to comment
  • 4 weeks later...

I had given up on it half a year ago, after upgrading to 6.11. it was broken, so I thought. I gave it a shot now with 6.12.2 with what I think made the substantial difference: I now use a "disk share" instead of a regular "user share". Disk shares may not yet be enabled on your unraid installation and this can be done in "Global share settings". The disk share has a size limit for timemachine. I don't see any substantial drawbacks of using a disk share as compared to a user share, if you plan to have you macOS backups all on one disk anyway. The SHFS user file system turns out to come with a lot of performance overhead and I have stopped using it for any shares for backup solutions.

 

I am using the unraid TimeMachine that is included with the OS, not the TimeMachine container. I had tried the container in the past and that was also not successful for me. I removed all custom tweaks for SMB, I am using the stock SMB config that 6.12 comes with.

 

TimeMachine now is not perfect, but it works: The inital backup stopped like 4-5 times and I had to restart it. The whole process took 2-3 days until the initial backup did conclude successfully. Starting new differential backups works fine.

 

I don't know yet whether the verification will be successful, as it is currently running. If it fails I will provide an update here.

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...