Jump to content

Can't 'retrieve share list from server: invalid argument' on Linux Mint


Go to solution Solved by awediohead,

Recommended Posts

I've just installed Linux Mint on a laptop we helped a completely non-techy friend buy. She's a close friend who cares for my disabled wife and the idea was that she would occasionally use our unraid server to back up various files when she visits.  I have done a lot of searching online to try to resolve this before posting here but I've found nothing that makes any sense as to why this shouldn't 'just work' especially since it's a fresh install of Linux Mint.

 

So on MacOS Finder I can easily (as I have for years) just enter the user share name and password when I get the 'connect as' prompt in the Finder. It immediately connects to my unraid NAS shares and lists the available folders.

 

When I try to enter the same credentials in Linux Mint's file browser under Network -> NameofmyNAS (File Sharing) I get

"Unable to mount location - Failed to retrieve share list from server: invalid argument"

 

In the past I've quite easily managed to access my unraid shares via my own Linux Desktop install which is a Fedora spin - and the searching I've done provides "solutions" that are so very far beyond my understanding and refer to a bug in gvfs not Samba on Ubuntu or talk about editing various conf files in the terminal - none of which should be necessary for something I'd have thought was pretty straightforward?

 

I suspect that once again something really fundamental in my understanding of how Linux works is the failing here - but for something to work flawlwssly on MacOS and not another Linux distro that's supposed to be super beginner friendly seems weird.

 

cheers

Link to comment
  • Solution

I can't say I've "solved" this by a long stroke, but I thought I'd post back here to say I found this thread useful

 

https://forums.linuxmint.com/viewtopic.php?t=318242

 

specifically this:

 

Quote

The "trick" here is to try to connect to the server without invoking gvfsd-smb-browse. You can do that by accessing the server and share explicitly in Nemo:

By mDNS host name ( hostname with a .local attached at the end 😞 smb://win10-host-name.local/share-name

By ip address: smb://win10-ip-address/share-name

And if you are really lucky ( meaning it will most likely fail ) by NetBIOS name: smb://win10-host-name/share-name

 

Though this mentions Nemo, I'd actually wiped Mint in favour of Pop OS by the time I found this, but the same applies to Files which is the Pop OS version of Nautilus

So what worked for me was to go to +Other Locations and totally ignore the supposedly handy direct Network links to my unraid server and other devices on the network. At the bottom of the Files window there's a field with "Enter server address" into which I put

 

smb://nameofmyunraidserver.local/nameofshare

 

I find it very odd that these things don't just work OTB between two machines running Linux (NFS didn't work either) and all the tutorials I could find target setting up Samba to share a folder on the machine you're on, rather than to connect to a share on unraid. If I've just missed a straightforward quality tutorial despite hours of searching please post a link!

 

This one from Matt Hartley was the best I've found so far:

 

https://glovesoff.substack.com/p/samba-on-linux-the-easy-way

 

 

 

 

Link to comment
  • 7 months later...
On 6/22/2023 at 7:36 AM, awediohead said:

So what worked for me was to go to +Other Locations and totally ignore the supposedly handy direct Network links to my unraid server and other devices on the network. At the bottom of the Files window there's a field with "Enter server address" into which I put

 

smb://nameofmyunraidserver.local/nameofshare

 

 

 

thanks a million - been struggling to logon to my UnRaid share via an Ubuntu VM and was hitting roadblock the same as you.  using your solution of +Other Locations and entering the server address solved my access issue.  prior to that it was always asking for credentials to log on which didn't work at all no matter what I tried.  fixed it for me!

  • Like 1
Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...