Jump to content

Very Slow SMB (and AFP) Transfers (iPad)

Recommended Posts

Hi everyone,

I am using a 3 x 2TB unRAID Server where I store all my media. I stream the media to a WD TV Live using a wired connection and have very good performance with regards to snappiness etc. (nearly identical to a USB HDD!). I also occasionally stream media to my MBP using Wi-Fi and the transfer speed saturates the Wi-Fi router (about 3MB/s - using 802.11g router with negotiated speed of 24Mbps).


The problem is when I try to stream media to my iPad. The actual data transfer rate was at most 100KB/s (tried to download some files using ezShare and FileBrowser). After numerous tweaks, I managed to get the transfer rate to about 300KB/s, which is still, well, disastrous.


I installed "TCP Optimizer" (from here: http://goo.gl/aXJXY), which increased the throughput. I think mainly because it disables TCP delayed ACKs.


I also added these attributes to the smb-extra.conf:

max open files = 16500
host msdfs = no
msdfs root = no
kernel oplocks = no
oplocks  = no
level2 oplocks = no
min receivefile size=16384
use sendfile=true
aio read size = 0
aio write size = 0
write cache size = 65536
domain master = no
local master = yes
preferred master = yes
os level = 50


I also tried AirVideo but it still hangs occasionally even at low bitrates...


Is there something I am missing? I would really be happy if I could stream HD movies to the iPad!

Link to comment

I stream to my ipad/iphone via XBMC.


My ipad is jailbroken and i installed xbmc on it.


I turned on UPNP inside xbmc on my mac mini.


i pointed my ipad to the upnp on the mac mini. bearly any dropped frames on 1080p via wifi on ipad..


i know there are better ways to do it. but this worked and hardly watch movies on my ipad so it was a no brainer.


Link to comment

With a transfer rate of about 300KB/s, I would be lucky to stream normal SD movies without problems...


Mac OS X has a long history of problems with SMB connections, so I believe some problems still exist in iOS. I believe that the problem can be fixed by a Samba setting from my unRAID Server to gain compatibility with iOS, as there doesn't seem to be any problems with other iPad users using SMB connections.


Anybody have any idea?

Link to comment


I created a SMB share from my MBP using Wi-Fi and managed a constant transfer rate of about 850KB/s (which is understandable as the data is transmitted and received through Wi-Fi).


So the problem is with the SAMBA or TCP configuration on the unRAID server, which for some reason is kind of incompatible with iPad.


I also noticed that when transferring a file using SMB on the iPad, the transfer rate starts off at about 400KB/s and degrades to about 250KB/s through the transfer.


Any help???

Link to comment



I installed unRAID 5.0beta12a to test using AFP. The transfer rate is the same as SMB (about 300KB/s) so the problem seems to be in the TCP settings of the linux kernel. I have tried the following sysctl parameters and have achieved an increase in throughput (max: 450KB/s, low: 250KB/s).


sysctl -w net.core.rmem_max=16777216
sysctl -w net.core.wmem_max=16777216
sysctl -w net.core.rmem_default=65536
sysctl -w net.core.wmem_default=65536
sysctl -w net.ipv4.tcp_rmem='4096 87380 16777216'
sysctl -w net.ipv4.tcp_wmem='4096 65536 16777216'
sysctl -w net.ipv4.tcp_mem='8388608 8388608 8388608'
sysctl -w net.ipv4.route.flush=1
sysctl -w net.ipv4.tcp_fack=0
sysctl -w net.ipv4.tcp_mtu_probing=1
sysctl -w net.ipv4.tcp_rfc1337=1
sysctl -w net.core.netdev_max_backlog=2500
sysctl -w net.ipv4.tcp_no_metrics_save=1
sysctl -w net.ipv4.tcp_moderate_rcvbuf=1

Link to comment


This topic is now archived and is closed to further replies.

  • Create New...