Jump to content

Parity and other serious errors during disk upgrade


olympia

Recommended Posts

My unRAID box logged serious errors during upgrading one of the disks (1.5TB->2.0TB).

The errors were logged not on the new disk, but on another (massive read and parity errors).

 

Syslog and smart report (short self check didn't finisih) on disk1 attached.

unRAID reported 1067 Parity errors after finished rebuilding the new disk (which is strange in itself, since this was a disk rebuild from parity).

 

I presume this means I have to consider the just upgraded disk8 (sdf) as corrupt and disk1 (sda) as a disk to be RMAd(Current_Pending_Sector=76; Raw_Read_Error_Rate=1840)?

Is that a fair statement?

 

Also, how can I recover from this situation? I still have the old disk8 with all the data on it. Shall I put this back, reset the array and initiate a new parity? ...and shall I remove disk1 from the array to avoid corruption and try to recover the data from it outside of the array?

 

Thank you!

 

Syslog: http://pastebin.com/qtScYvHm

smartreport-sda-2011-09-18.txt

Link to comment

OK, finally I pulled out and replaced disk1 (sda) which reported 1840 read error and 76 pending sector.

 

Then the followings happened:

- I ran preclear on it and preclear reported 1 pending sector after post read (so -75 pending sector in total)

- I ran preclear once more and then it reported 0 pending sector

 

But there was no reallocated sectors reported.

So shall I trust this disk? I presume no, but could anyone please explain what could be this (pending is not going to be reallocated at the end)?

Link to comment

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...