Jump to content

Server Will No Longer Boot - BIOSTAR A760G M2+


zack84a

Recommended Posts

Motherboard - BIOSTAR A760G M2+

 

UNRAID Version - 4.5.6

 

Recently changed out the CPU fan, as I needed the current fan for another project. 

 

Server started with no problems with new fan, however was a bit loud.  I went to bios and tweaked CPU fan settings.  After reboot server wouldn't come back up.  After finally hooking up a monitor I realize I am stuck at hardware settings.

 

I have reverted change, and per wiki setup the bios as it should.  When settings are perfect, I now receive a message stating that I have an improper boot drive, though the flash drive has never changed.

 

Per bios the only drive available to boot is my flash drive.

 

Curious as what to try next.  I have tried moving the flash drive to a new port with no avail.

 

Only idea I have left would be to reformat the flash drive as boot and re-add UNRAID, my only question would be to what files do I need keep to ensure the server will boot up correctly, and remember current state of unraid.

 

Any other suggestions would be greatly appreciated...

 

Thanks for any and all help.

 

Link to comment

For most BIOS you must both set the option to boot from a USB drive and ALSO select the specific flash drive in the set of disks available to boot from.  In many cases, the flash drive will appear as a bootable hard disk in the listing.

 

Many BIOS "help" you by resetting the boot drive to any newly installed hard disk.  Upon adding any new disk you must reset the boot device to be the flash drive.

 

The very last thing you should do is mess with the flash drive.  Odds are it is perfectly fine.

Link to comment

This is what I would do, I'd grab another flash drive and format it with a fresh copy of unraid. See if you can get this one to boot. That way you will know if it is your motherboard or flash drive.

Basically, if you do create a new flash drive, in most cases, all you need to transfer from the old to the new is the contents of the config folder.  That will preserve the disk configuration.

You might also need to save and restore any other customizations you might have made.

 

However... running syslinux to make the flash drive bootable does not change the contents.  You might just try that one step and all the contents will be intact.

 

Also, run checkdisk/scandisk on the flash drive.  It might be as simple as that to get it to boot.

Link to comment

Thanks for the help all.

 

Joe, running syslinux on the flash drive ended up being what fixed it.  Not sure how or why that got corrupted, but glad I am back in to business.

 

Thanks again.

 

 

keywords for others in the future:

unable,boot,flash,drive,system,diagnostics,screen,stuck

Link to comment
  • 4 weeks later...

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...