unRAID server freezes after the Synology NAS is turned on


XiMA4
Go to solution Solved by XiMA4,

Recommended Posts

Hey, unriders.
My problem is that the unRAID server freezes after the Synology NAS is turned on.
It's just mind blowing.

 

My setup:
Syno NAS is just a backup device, automatically turns on every night at 2:10 and turns off at 9:10.
The unRAID server has been running 24/7 for years. Both servers are on the same subnet.

 

Normally I don't upgrade to a fresh release but wait for .1, in the case of 6.12 I upgraded later, surely .4 will be fine, I thought. But that was a mistake, after upgrading from 6 .11.5 to 6.12.4 I started having 40-50 minutes of freezes at night. I started experimenting with network settings (bridge, macvlan and stuff). But periodically the freezes would happen, it wasn't every night, but several times a week the CPU load would increase to 100% and access to the GUI would become very difficult, but would persist. It was hard to find a reason why this was happening, it was always at night and not all the time. After upgrading to 6.12.5 and then 6.12.6 it got really bad. The server would always stop responding, even over ssh, after SynoNAS automatically started.

 

Does anyone have any ideas, I would be grateful for any hints.
I had to temporarily disable the backup server.

 

unraid-diagnostics-20231202-1249.zip

 

Link to comment

syslog-10.1.1.20.log

 

4 hours ago, JorgeB said:

Enable the syslog server...

 

 

I tried repeating the situation during the day, just manually running my Syno. The unRAID hung as expected. I rebooted it and after about five minutes it booted up, I started the array and almost immediately lost access to the GUI, I should note that docker has no effect on the situation, I had previously tried disabling docker autostart but I still lost control of the server after starting the array. I couldn't connect via ssh either, but the server was pinging.
After about ten minutes I got control back.

 

Ten minutes is a long time, during this period of time many network connections are dropped and Plex clients' buffers are emptied.

 

Edited by XiMA4
Link to comment
1 hour ago, JorgeB said:

Only issue I see is the OOM killer getting invoked.

thanks for the reply

 

This is not an issue, but a consequence of the issue, and I can't figure out the cause.
It happens only once when I turn on the device, no matter Synology or unRAID. If I turn it on automatically according to Syno schedule, then unRAID freezes, then I turn off unRAID and start it up, it freezes again. If I leave both running, the problem does not recur.

 

Something burns up all the memory, the system closes some process, from what processes are closed and depends on whether the system will work further and when the control will return, it happens that 10 minutes, it happens that an hour, and it happens that the system hangs intentionally.

 

On Syno I did not make any changes, unRAID is updated - hence the problem is in the update.

 

Edited by XiMA4
supplemented
Link to comment
  • 3 weeks later...
  • Solution

I have solved my problem, so that ends the question.
First I moved my Syno server to a different subnet and one problem was solved, but the intermittent disappearance of the user directory as described here was still happening, so I moved my array to another server, TueNAS Core. Now the problems are gone and hopefully won't come back.
Now my unRAID only works for docker containers.

 

upd.

I shouldn't have hoped for anything. Some problems remained though. Several times I noticed that I could not access the web interface. If you leave it for a while, the control comes back.
Honestly - I'm getting tired of looking for solutions to problems, 6.13 is coming soon and new problems. The system should just work for me, but in this case I am working for it. I'm moving the main docker containers to other servers. UnRAID will be a test environment, I will wait for the developers to fix the bugs.

 

Edited by XiMA4
Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.