Jump to content

Cannot connect to Plex Docker Web UI

Recommended Posts

Hey everyone. I made sure to do some digging before bringing this here.


I just recently replaced my ISP Router/Modem combo with a third party router and modem (separate devices). We had the 10.0.0.x IP Address, but they got changed to 192.168.0.x. I was able to change the network settings in Unraid without issues, and can connect to the interface without an issue. I also have a VM running a web server that I have no issues connecting to locally on that 192 address space.


I'm now seeing an issue with my Docker. Specifically my Plex Docker and possibly another, but the Plex is my current issue. The Docker starts without any visual error when starting the Docker. I also looked at the log from the Unraid interface, it's showing that the "Server is unclaimed" and "No custom files found, skipping" but I don't think that could play in part to the issue with connecting.

I also looked in the following log directory: /mnt/user0/Library/Application Support/Plex Media Server/Logs

But all of the logs are dated back to 2018. So is this a logging issue, or is everything fine? Permissions for those files is -rw-r--r--, so it shouldn't be permissions. Is there another location I can get logs that will actually tell me something?


I am running this Docker in Host mode. And it is getting the following: <Media Server IP>:1900/UDP <--> <Media Server IP>:1900

<Media Server IP>:32400/TCP <--> <Media Server IP>:32400.


I just ran netcat from another host on the network. nc -zv <Media Server IP> 32400 | with a "Ncat: Connection refused", is there a way to allow that port?


Link to comment
  • 1 month later...

I wanted to follow up.  I noticed that both of the files "Preferences.xml" and "Setup Plex.xml" in the "Plex Media Server" had a size of 0 kb.  So after hours of wasting my time reading, googling, reading and retrying configurations that had worked for 5+ years I just deleted them and restarted the docker container which enabled it to work.  I did have to reconfigure some settings but it enabled the docker to start.


I had backups from the plugins but I couldn't just grab the few files I needed and was forced to overwrite everything from what I could tell which was a no for me.  

Link to comment
  • 1 month later...
On 2/25/2024 at 1:07 PM, sidekickfont said:

I don't think its your ISP.  Nothing changed on my side and I am having the exact same issue starting on around Feb. 15th which I am unable to fix.  Everything else works but Plex and its giving no real errors and is running.



Has anyone else experienced this behavior....Usually when some database error or something else was causing plex sterver to stop workning I've seen them here in the log.   In recent weeks I've noticed every couple of days (sometimes every day) sudden stops. No info, log or anything...just can't connect through client nor webui. Can't pin it to anything I can imagine...everything else works fine...I cleared and checked cache...docker image size etc...  Rebooting docker helps instantly but just for another day or so.  I have regular setup, Nginx proxy manager and currently without any rsync etc...just local mnt.  One workaround though with app folder being forwarded straight from cache to bypass "unraid speed toll". Worked fine for months...maybe recent unraid upgrades changed behavior of direct cache ?   I have setup sonarr and radarr same way...they work fine....

Any ideas?

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...