Jump to content

trouble replacing a disk - switching IDE to SATA


bdee1

Recommended Posts

I have an older unraid system - its on the current build but older hardware. 

 

I have the following:

COOLER MASTER CM Stacker STC-T01-UW Case

ASUS P5PE-VM LGA 775 Intel 865G Motherboard

PROMISE ULTRA133 TX2 PCI IDE 66M PCI Controller Card

PROMISE SATA300 TX4 PCI SATA II (3.0Gb/s) Controller Card

 

I have 4 IDE drives connected to the PCI ATA controller card.

I have 7 SATA drives.  6 are connected to the SATA ports on the motherboard and one connected to port 2 on the  Promise SATA controller card.

 

I want to replace one of my IDE Drives with a SATA drive.  Last night i removed the IDE drive and added in the SATA drive and connected it to the Promise SATA card and i could not get the system to see it once I booted up.

 

I tried going into the BIOS config but that only controls the onboard SATA ports.  I am not sure how to make it see the new drive on the Promise card.

 

Does anyone know if there is some kind of config utility for the promise card?  Or is there something else I need to do to get the system to see the new drive?

 

I would really appreciate any assistance.

Link to comment

Agreed with the previous post - you want to make sure your disk isn't DOA.

 

I don't think I'm familiar with your specific SATA controller, but most controllers I've seen will have a BIOS that boots up when the machine is restarted.  Usually, you'll see the connected drives that the controller can see, but sometimes you have to get into the controller's BIOS to see the drives.  (There should be a hot-key to get into the management application during bootup.)  I've run into a few controllers where you have to get into management and set the drive type to be RAID/JBOD/etc prior for it being recognized.  Or you might have to enable the port or something like that.  Check your controller's documentation for specific instructions.

 

Also, just check your drive's power and SATA connection.  I'd suggest conducting isolation testing with different cables and possibly ports on the controller if possible.  You can even try to put the new drive in another machine to see if it can be accessed at all.  This will isolate the controller, cables and everything else within your unRAID system.

Link to comment

thanks for all the suggestions - i wound up getting it resolved.  I was removing an IDE drive to put in this SATA drive and when i removed the IDE drive it was throwing things off.  I had to change the jumper settings on that IDE chain so that it woudl see the remaining IDE drive properly and then everything worked.

Link to comment

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...