Jump to content
We're Hiring! Full Stack Developer ×

Help with SMART Error when starting Preclear [Solved]


TODDLT

Recommended Posts

OK, you've I've posted several threads this weekend that area all part of me buying two new drives and moving drives around both in and out of the array.

 

I'm at the final stage, and preclearing two drives.  One is a year or two old NTFS formatted drive I am preclearing to add to the array, and one is a USB external drive I will not have in the array.  Just using preclear to test it before formatting it NTFS on a Win 7 computer.

 

The USB drive is showing up as dev sda and the other drive is dev sdd.  I have attached screenshots of the error I get in preclear.  It says I can continue, but I want to know what the issue is before I do as I've never got this on a preclear before.

 

Thanks

Hit_Touro.jpg.37a0abca42f3b4dd23d26572b762ea1d.jpg

Link to comment

Here is the other drive, sdd

 

Ignore all the stuff above the start of preclear.  I tried to highlight and right click on the text to do a copy paste in a telnet session.  I didnt expect it to work, but tried and that's where all those lines came from.

WD10EALS.jpg.f2c54c750cd958fac2cd8770959e3041.jpg

Link to comment

Not sure if it's relevant but also see this in the syslog.

 

Oct 15 09:19:50 TODD-Svr kernel: sd 0:0:0:0: [sda] Assuming drive cache: write through (Drive related)

Oct 15 09:19:50 TODD-Svr kernel:  sda: sda1 (Drive related)

Oct 15 09:22:08 TODD-Svr ata_id[4407]: HDIO_GET_IDENTITY failed for '/dev/block/8:48'  (Minor Issues)

Oct 15 09:22:08 TODD-Svr kernel:  sdd: sdd1 sdd2 (Drive related)

Oct 15 09:23:58 TODD-Svr ata_id[4856]: HDIO_GET_IDENTITY failed for '/dev/block/8:48'  (Minor Issues)

Oct 15 09:23:58 TODD-Svr kernel:  sdd: sdd1 sdd2 (Drive related)

Link to comment

If updating the preclear script doesn't work, try a different port in your system...like a motherboard port.  Although I haven't hit it personally, I've read a few reports on the forums where some controllers don't play as well with smartctl as others.  If it were me, my goal would be to get a nice, clean report...and even though this error might not affect the preclear, for my comfort...I'd want it to run optimally unless there were no other options.

Link to comment

I need to watch that.  I didn't realize the script was out of date.  I've downloaded and will copy over to the unRAID flash.

 

I started the preclear earlier after running a smart report on the drive and not seeing any issues.  I'll wait for it to finish since I only started one cycle, then copy over the new preclear, and run it to see what happens.

 

I can try a different port but here is the puzzling part.

1. I just precleared two brand new 500 GB Hitachi drives without error.  One of them was connected to this port / cable.

2. I have already precleared an identical drive to the one connected to this port months ago.  It was bought at the same time and is currently plugged into a different cable on the same SAS port for this card.  

3. I am getting a similar smart error trying to preclear a usb connected drive.  (see above).  this is a totally different interface.

 

Because of thsoe reasons, i'm leaning away from it being a port issue, but will try anything to rule it out completely.

Link to comment

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...