Jump to content

New 5.12a now 4.7.1 install - Lost Web UI when root password assigned


Merlin

Recommended Posts

The system in a Dell 8400 Pentium 3 with 3MB ram. It has 3 new Samsung 2TB disks. Disks were precleared then system was configured through web UI. I installed version 5.12a and even though this is my first jump into a Linux/Samba system everything proceeded probably because I followed the checklist at mediasmartserver.com It was for an older version checklist but I found most things after bit of digging around the gui.

The name was changed from Tower to match existing naming pattern.  I set up one user share across the non-parity drives (sdfb and sdc) then decided to change root password before going on with more shares. When the server finished processing the password change my web ui went blank; just a plain white page.

I tried multiple browsers but got the same result I went to the terminal and the server was up and everything looked as far as I could tell well. I decided to reboot and the server came right up. I logged in with the new password I sent and it worked perfectly. I went back to the UI but had no success.

I connected via telnet to try and read syslog but keyboard input wasn't shown on (PUtTY) though when I later was able to review syslog it showed showed the connected had been made

I searched the forums here and found various wed interface lost quotes but none seem to fit my situation. The system power supply is quite capable of running these disks, it had 4 in it prior to this change and isn't an old PSU. It's up but I can't work on it through the gui so help would be appreciated.

Syslog is attached

 

Merlin

syslog.txt

Link to comment

Does anyone from Lime Tech actually answer these? ??? Just curious. Lots of views but no replies. System sitting here waiting to be used but I'm not putting any data there until I can create more shares and work from the GUI when I need to.

 

 

Everything looks perfectly normal in the syslog.

 

You will probably need to reboot your PC and/or router for them to know the new name of your server.

According to your syslog, it should be assigned IP address 192.168.123.187

 

If you cannot access it by name, try via IP address.

Enter

http://192.168.123.187

on your browser.  What do you see?

 

And no, lime-tech seldom posts.

 

Joe L.

Link to comment

I restarted the PC and the router shows the correct server name in the routing table. I connected by IP address so I didn't fat finger the server name.

The browser brings up a blank page - all white. I tried on my laptop and got the same thing, blank white page but I can ping the server and at the terminal all appears well. The terminal emulation in either PUtTY or Crypto Term gives me an unresponsive screen. Crypto term give a yellow connecting ... status but never connects with with the login and password embedded. You saw in Syslog what happens when I connect with Putty.

 

Re: Lime Tech :Ah well I guessed as much but one can always hope. I did email them but of course am way down their list of things to care about.

I'd try Nextena but I fear the hardware list wants a newer board that my old Dell has to offer.

 

Link to comment

Not particularly. I pulled the bzimage and bzroot files from 4.7 over to the flash drive and rebooted. Server came up fine but I still get a blank page when I try the web GUI. Could I have changed a setting that would cause that?  ???

 

 

What URL are you using???  (exactly)
Link to comment

Okay so here's what I know.

I did install 4.7.1 on a new flash drive. Everything went fine UNTIL i gave root a password. As soon as I did that the web GUI was no longer accessible. At first I thought it was that the password configuration but I powered down removed the password specific files and suddenly my GUI was back. I created my shares and the last thing I did was add a password -123456- I can now telnet into the terminal but I still have no GUI. I assume the server should pop up a login screen similar to the one on my Samba NAS but neither Firefox or IE will connect. IE simply says it cannot display the web page. I'm using the IP address to connect so I am sure it's right.

If I enter \\serevrname\ or \\xxx.xxx.xxx.xxx\ into my browser the server and shares show up as folders. I can copy and delete files to the folders but there are no users set up aside from root so I'm unable to restrict access by user. But http://apollo_eemc/ brings up the can't display web page screen.

 

Idea's appreciated  ;D

Link to comment

I turned off my internet security suite completely but it made no difference. If I simply enter the Ip.add.ress the page still loaded blank. I remembered that someone said by adding :8080 I might be able to see the server and I can - screen shot attached - but none of the links work because I cannot get it to ask me to login. This is if I simply enter the Ip.add.ress then :8080 If I open Internet Explorer and enter the Ip.add.ress or the servername I get windows file explorer open to the shares with no password protection and no login required. I can add or delete files at will  Nothing I do in Internet explorer allows me to see the web gui. That's my Windows 7 X64 Home PC - my Win 7 X64 laptop behaves the same way. BitDefender Internet Suite 2012

I have an XP Pro laptop running Symantec Antivirus that I use for work. Normally I do nothing but work related stuff on it but I tried opening the unRaid server and there was my login screen. I logged in and there was my GUI.

So Windows 7 + Bit Defender doesn't work. Turn off anti-virus and firewall makes no difference

I can get the screen shown inthe attached capture up by using the :8080 but it's just a picture, nothing works.

Windows XP Pro + Symantec AV Connects as expected.

I'm confused as usual.

unraidguism.jpg.a8a96d490f55a943419bfb8676316e31.jpg

Link to comment

@ dgaschk  It runs on a WIN 7 X32 system as well.

I found out by going through the old "turn everything off and if it works turn stuff on one at a time" routine, that apparently even when Bit Defender is turned off it isn't. In safe mode I can connect. I turn off Spybot's Tea Time and Bit Defender - all items related to it about 4 I think. I can turn Spybot on and it still connects but when I turn on BD it won't.

I chatted on-line their tech support this afternoon for a couple of hours and they were stumped as well but level 2 said BD was partially on even when it was off. I guess that's good protection but annoying in this case. I had whitelisted the server before and turned off HTTP scanning as others had trouble there but it made no difference. So I zipped up their logs and sent it to their upper level support to figure out.

 

@ Joe L Never needed a name server internally, everything broadcasts a name in the workgroup except the Spiceworks equipment monitor,  TV, DVR and Blu-Ray player. Nominally the Cisco serves DHCP and Name service but of course it's limited to broadcast names. The UnRaid does broadcast it's name and in a couple of instances I've received a " cannot connect to apollo_eemc."  I suppose it can't hurt.

 

Link to comment

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...