Jump to content

[SOLVED] Read only drive with wrong filesystem


Recommended Posts

I am running version unraid server pro v 4.7, with nine 2TB drives; one parity drive and eight data drives.  I have a separate cache drive and boot drive. I use Sabnzb and Sickbeard to download TV shows and manage them.

 

Data disk 7 and disk 8 were empty for some time and were in the system for about 3 months with basically no activity.  Recently drive7 started to get used.  The drive failed and the system took the drive out of the raid.  I followed the procedures outlined in the LimeTech wiki at http://lime-technology.com/wiki/index.php?title=Replacing_a_Data_Drive and replaced disk7 with a new 2TB drive (it was a Hitachi and I replaced it with a Seagate). The process seemed to work flawlessly and after a few hours, all seemed well.  The drive was back in the system and all seemed good. Note that I did not preclear the drive as it was not recommended in the wiki, nor did I know how to preclear before the rebuild.

 

A few days after the successful drive replacement, a problem started when my downloads were being successfully completed in Sabnzb but not appearing on the Unraid server.  Reviewing the Sabnzb log file showed a write failure due to lack of write permission.

 

I did not think much of it and re-downloaded the missing TV show.  Same result.

 

I looked at the directory where I expected the file to be and noted that the ownership and read write privileges were all off.  Tried chmod, chgrp and chown to fix. None of these worked with the error that that there was read only privilege. (I was logged in as root). In UnMenu I checked the filesystem of disk7 and it was “unknown”.  All the other drives were a filesystem of reiserfs.

 

I still had read access to disk7 and copied about 200g of data to my desktop computer as a backup. I paused Sabnzb so no new downloads would occur.

 

I ran reiserfsck as per wiki http://lime-technology.com/wiki/index.php?title=Check_Disk_Filesystems

Ran resierfsck –check and it told me that I had a corruption  which could be fixed running with –rebuild-tree

 

The rebuild completed successfully with a lost+found directory being created with lots and lots of files. Many files were missing, and some directories actually seemed to be bigger than before, but I was not worried as I had a backup.  I checked the filesystem type of disk7 and it was still “unknown”. It appeared like the disk was still read only.

 

I am stuck now and looking for assistance on how to get the new drive to be a recognized filesystem. Any advice would be appreciated.

 

Thanks

 

Link to comment

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...