Jump to content

Gigabit Switch Issue


Shadey1

Recommended Posts

Evening all,

 

I've had a search and I've not seen anything that seems similar to this.

 

Basicalyl my new Gigabit switch does not seem to recognise that the unraid tower is plugged into it. It was working when I had them jury rigged through an old router not so long ago, since I added the switch tonight the network shows everything but unraid.

 

Ok we moved house, Unraid, and new pc went with us. I've tried to do a diagram as below. We're a bit limited as to where things go with the size of our new place.

 

Phone Line - Router  -> XBMC

                            -> TV

                            -> Powerline adapter  ->  Powerline adapter -> Gigabit Switch -> Main PC

                                                                                                                -> Unraid

 

Now everything is wired up with cables that worked previously the only addition to the old network is a new gigabit switch. Netgear Prosafe 5 to be exact.

 

Any suggestions, my network knowledge is beyond rusty I'm afraid.

 

I've cycled power on everything. Switched ports around, and with all 3 pc's fired up the only one not on the network is the unraid tower....which is causing my much grief off the other half lol.

 

Cheers all.

Link to comment

The router was set to DHCP, which made the most sense as it needed to allocate the net etc. Now I've turned it off to play with the settings, fixed some IP's etc. Turned off UpnP and it picks up the net, but it still can't see UNRAID.

 

Not sure how to get the switch to DHCP etc?

 

It's this switch http://www.netgear.co.uk/business/products/switches/unmanaged-desktop-switches/GS105.aspx

 

The Main PC show's as an IP.

 

And yeah Dynamic IP from the ISP.

 

Even wierder I've now removed the switch and put the UNRAID direct into the router and it can't see it :/ I'm stumped. Utterly stumped now.

Link to comment

Right I assumed this, I was a tad confused when he mentioned DHCP in that context, but as I say been a while since I had to get my head around it. Yeah I've been chopping and changing cables as well as wiring configs. Colour me deeply confused.

 

I've (last 15 mins) taken the switch out of play, and plugged the UNRAID into the router and my Main PC, now the network is just showing the MAIN PC like unraid isn't even there!!

 

I've got another router tucked away at my parents so I want to see if that can see it, and it's not just my new router from Virgin. But I cannot imagine why my new router would not be able to see a Linux share.

Link to comment

On the UNRAID server go to the console and type: IFCONFIG

 

On your Windows PC go to a command prompt (Accessories | Command Prompt) and type IPCONFIG /ALL

 

Post your results here.

 

This should give enough information to provide a reasonable diagnosis of your issues.

 

The most likely situation is that your unRAID server has a fixed IP address which is on a different subnet than your Windows PC.

 

edit: I've looked through your old posts. Please ignore this advice if I am wrong, however are you sure you have the network cable plugged into the correct ethernet port? You added a Netgear NIC to your UNRAID server some time ago and disabled the onboard Ethernet. You need to check that the network cable is connected the Netgear NIC.

 

Link to comment

Morning, I'll check the IP's when I get in from work, good shout.

 

It's definately in the right NIC, I checked that first! I've even tried the other NIC :/

 

EDIT: Any suggestions if when I'm logged in UNRAID tells me ipconfig or ipconfig eth0 is command not found?

 

SIGH. Long day, IFconfig lol

 

 

Link to comment

Yeah hit me seconds after i posted, long day lol. thanks I'll report back asap.

 

EDIT: Ok here we go.

 

iFconfig gives me: a MAC (HWaddr) of 00:11:3b:15:3d:02

inet addr:192.168.11.67

Bcast: 192.168.11.255

Mask:255.255.255.0

 

Windows: 192.168.0.3

Subnet Mask: 255.255.255.0

Default Gateway:192.168.0.1

 

So, and I'm attempting to make an educated guess here, the fact they're on different IP's is my issue. Looking at the configuration tutorial I can force UNRAID onto a static IP which in theory could fix this? Though as I say educated guess, is it obvious it's been years since I did anything majorly networky?

 

Thanks.

Link to comment

Is windows getting its IP address from DHCP (that appears to be the case)?

 

You could quickly try changing the IP address of your Windows PC to 192.168.11.66, subnet mask 255.255.255.0, that should allow you to access your unRAID server web interface.

 

From the Web Interface you can change your IP settings by going to Settings | Network Settings. I suspect that you'll find the 192.168.11.67 address is fixed.

 

(Note: I'm using version 5 of unRAID so I'm not sure whether this applies to older versions or not).

 

If you can't access the network settings through the web interface then you can go to the Flash disk share and manually edit the config\network.cfg file.

 

Here's what my network.cfg file looks like:

 

# Generated network settings

USE_DHCP=yes

IPADDR=

NETMASK=

GATEWAY=

 

I would recommend using DCHP rather than a fixed IP address.

 

Once you have changed the settings to your liking make sure you set Windows back to using DHCP.

 

Link to comment

First of all, it's a switch so it doesn't have DHCP capabilities. Your router needs to provide that service.

 

Not 100% true to be fair. many Cisco switches provide DHCP.

 

I troublshoot networks day to day. I start off from the root and work back.

 

In your case i would Check first

 

Phone Line - Router  -> XBMC

 

Then

 

Phone Line - Router  -> TV

                       

Then just for the sake of checking remove the power line adapter out of the situation and see if unRaid then works.

 

Phone Line - Router  -> Main PC

                            -> Unraid

 

You really need to work a step at a time until you see what may be the cause. Maybe there is a mis match on the power line adapter. Also you may or may not have changed this but check the speed and duplex setting on the main PC and unraid. It will not be the first time i have seen a PC set to auto and the swith set to 100/1000 Full duplex.

 

Craig

Link to comment

# Generated settings:

USE_DHCP=no

IPADDR=192.168.11.67

NETMASK=255.255.255.0

GATEWAY=192.168.11.1

DHCP_KEEPRESOLV=no

DNS_SERVER1=90.207.238.97

DNS_SERVER2=90.207.238.99

DNS_SERVER3=192.168.11.1

 

Would appear to be my culprit.

 

I'm going to adjust it to auto, replug it all in and try it direct into the router first then move my way back up to the switch. Gonna be a few hours of moving and plugging but I'm now hoping it will kick in. I will update once I know as I would bet I'm not going to be the only person to face this in the future.

 

I've gone step by step and at no stage since switching routers has UNRAID shown up, stick in the old router and it's there but that has a different IP range.

 

Anyway thanks guys, I'll keep you informed.

Link to comment

colour me confused....

 

I reset the config file....rebooted it all....it's reverted back to dhcp off etc.

 

I'm guessing there must be another setting somewhere up in UNRAID reverting it each time.

 

You may need to shut down your unRAID server, remove the USB and edit the file on another computer. Keep a backup of the original file just in case.

 

Link to comment

That's what I did!

 

Shut down, pulled the usb, edited it, and started it up!

 

I'm thinking it might be worth re-installing unraid at this point.

 

EDIT:

 

I've forced the router onto 192.168.11.1 et voila, it see's unraid!!

 

Now if I can sort out the rest of our gear onto it I'm onto a winner. That and factoring back in the switch so I can store it all away again. No idea why UNRAID keps defaulting back to that IP though, all I can assume is something is going on that I've somehow set and it's overwriting the config file.

Link to comment

No idea why UNRAID keps defaulting back to that IP though, all I can assume is something is going on that I've somehow set and it's overwriting the config file.

 

I'm not familiar enough with unRAID yet to answer that question. One of the longer term users might be able to help with that one.

 

Link to comment

Righty jsut a quick update, since I forced the router and the DCHP onto the same IP as the unraid server all is good, it see's it it works etc.

 

Absolutely no idea why UNRAID is defaulting to that IP but once I got the rest on the same page I've got it all up and running now.

 

Thanks for the help guys. Massively appreciated. Hopefully this might help someone else in the future.

Link to comment

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...