Jump to content
We're Hiring! Full Stack Developer ×

[SOLVED] XP & Win7 cant access unRaid after cache disk offline


JudyZ

Recommended Posts

Hi there

 

My unRaid machine (Tardis) has run unRaid Server Plus 4.7 fine for months.

 

I started a 400+GB copy to it from Windows 7, and Tardis became unavailable part-way through (\\Tardis is not accessible. You might not have permission to use this network resource.)

 

Checked the syslog (attached) and noticed the cache drive wasn't there, so wiggled the connectors, powered Tardis back up and the system looks ok (serial nos. removed below for readability):

 

Disk status

  Model / Serial No. Temperature Size Free             Reads Writes Errors

parity WDC_WD20EARS 29°C 1,953,514,552 -             186 249 0

disk1 WDC_WD20EARS 31°C 1,953,514,552 486,799,632 136 88 0

disk2 WDC_WD20EARS 31°C 1,953,514,552 1,235,638,428 133 80 0

disk3 WDC_WD20EARS 34°C 1,953,514,552 666,713,952 130 84 0

cache ST3808110AS 28°C 78,150,712 78,115,480 64 82 0

 

unRaid started a parity check, which I cancelled.

 

Now, my Windows PCs can all browse to //Tardis, but none of the shares work (see attached image).

The net address is unchanged, the PCs connect through the same gigabit switch, so I think it's a share issue?

 

Typing  /root/samba stop at the console, gives no error message so the Samba service seems to be started ?

 

Settings:

Identification

Server name: Tardis

Comments:

Share security: Simple

Workgroup: JUDYZSYNX

Local master: No

 

Export settings

Flash share (SMB): Export read/write

Disk shares (SMB): Export read/write

Disk shares (NFS):

User shares: Enabled

 

Cache

Min. free space: 2000000

Mover schedule: 40 3***

Mover logging: Enabled

 

User shares look like

Share name: Blu-ray

Comments:

Allocation method: High-water

Min. free space:

Split level:

Included disk(s): disk2

Excluded disk(s): disk1,disk3

Use cache disk: Yes

Export (SMB): Export read/write

Export (NFS):

 

Please help! Any suggestions welcome ...

 

Thanks, Judy

syslog.txt.txt

no_tardis.jpg.727764cb693926b357b0bdd5c30208a1.jpg

Link to comment

Many thanks! The Cache drive is 80GB, so that adds up...

 

For the shares, I've restarted clients, server and the TPLink switch several times without effect.

 

If I click diagnose on a Win7 client it says the server is refusing the connection.

 

Can I delete and recreate all the shares without harming my data? (The manual says 'When User Shares are enabled, unRAID OS will automatically create a set of shares named after the top-level directories found on each data disk') I don't need User shares, but could try this - if it's safe?

 

Thanks again for the reply :) Judy

Link to comment

None of the shares are visible on the client machines - not even the flash or disk1/2/3 shares auto-created by unRaid.

 

Only the machine name (Tardis) can be seen - as in the attached...

 

If one browses to //Tardis with Firefox, the User shares are visible.

 

Yes, if I create a new share in the browser, I can then 'delete' it by blanking its name and clicking apply.

 

But if I blank one of the shares with data in it and click apply, it remains (phew!)

 

Thanks, Judy

no_tardis.jpg.5a490679a6e761dc1713004e9f357548.jpg

Link to comment

Ok - flash drive reformatted and clean installed. Have assigned drives correctly and started the array.

 

Disks2 and 3 are as expected, but Disk1 says unformatted (screen grab attached).

I've cancelled the parity build and not yet recreated the shares.

Have I lost the data on Disk1?

The share I was writing to when unRaid became unavailable included Disk1.

 

What would be the best thing to do next... ?

 

Thanks again!

Judy :-\

Main_after_USB_format.jpg.b931be5702f42eeb0ae6513e0a526690.jpg

Link to comment

Getting a bit braver ...

 

followed Joe's instructions for an unformatted drive at [Topic: rebuilding USB now drives say Unformatted]

 

and the drive is now showing formatted - it was an MBR/file system start block mismatch - yey!

 

The previous Shares reappeared - and are accessible from XP and Win7 clients !!

 

(the only changes needed to the Shares were to re-specify the Included & Excluded disks)

 

So problem solved, am letting the parity drive rebuild, and [ahem] will remember to remove the Cache drive if doing large copies :-[

 

Thank you so much DGASCHK - this forum is just fantastic, and one of the key reasons I chose unRaid.

 

Judy  ;D

Link to comment

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...