Jump to content

Three servers on 6.12.9 drives no longer sleep after upgrade from 6.12.8

Go to solution Solved by JorgeB,

Recommended Posts

After updating to 6.12.9 on all three of my servers, their drives will not spin down automatically. These servers previously spun down as expected after the time-out. Two of them are used once a day and only need to spin up at that time. No configuration changes were made besides updating all plugins before upgrading. Considering downgrading one as part of the diagnosis. Is there a bug in 6.12.9 for disk sleep?


Getting diagnostics soon...

Edited by wildfire305
title more detail
Link to comment
  • wildfire305 changed the title to Three servers on 6.12.9 drives no longer sleep after upgrade from 6.12.8

The one server I was considering downgrading (cvg05) has now started sleeping on its own. That server only has an rsnapshot container running and a speed test container. The other containers are not used unless the primary server is down and they are started manually. It has no external shares and it pulls backups through ssh from other servers on the network once a day and has no external shares enabled. Nothing is able to write to it by design because it is a backup server, therefore the disks sleep after the backups complete and they stay asleep until the next daily backup. It uses a small SSD cache for appdata, domains, system. It has one VM that boots debian and displays a webpage on a monitor.


The other two servers disks remain awake and the drives are not being commanded to sleep according to the disk logs. I can usually see if I have a thing that is keeping the disks awake in the disk logs by seeing them spin up and down, but that isn't showing up. I had previously moved all highly active file activity to a always on zfs pool and the array is now just WORM policy type stuff. My array disks on both servers are only supposed to wake up during Media Streaming activity. This has been a working design for me for the six months prior to the 6.12.9 upgrade.

Link to comment

This is what I mean when the command to sleep the disks isn't showing up. Usually if I have something keeping the disks awake, I see a lot of "spinning down" followed by "read SMART" when the disks are awoken by the process reading files. I'm not seeing the spinning down and the reads/writes are not increasing in count.




Link to comment
Posted (edited)

This worked on two of the three servers. I added a reboot in between disable/enable.


Try disabling and re-enabling spin down, if it doesn't do anything it suggests something is keeping the drives up, so it never tries to spin them down.


The third one was resolved by watching the disks that woke up from manual spin down command with

find . -mmin -30

This showed that some metadata on existing old files was being modified by an hourly rclone process. Not sure why OneDrive has started modifying metadata on files, but since it gets modified, rclone syncs the changes. If there are no changes the disks don't wake up.

Edited by wildfire305
  • Like 1
Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...