Red ball drive during parity check after adding 2 discs [SOLVED]


7 posts in this topic Last Reply

Recommended Posts

I added two new discs, and was running a parity check.

 

Disk 4, my sdl, has red-balls with errors reported through the unraid GUI.

 

I have attached my syslog, and a smart report.  First time I ran the smart report it failed with an error, couldn't find the drive.  Ran smart report with a bit different text to store direct to my USB, and it worked.  But when I tried running a short smart test, but it failed, saying:

 

Device Read Identity Failed (not an ATA/ATAPI device)

A mandatory SMART command failed : exiting. To continue add one or more -T permissive options.

 

I have not written to the disc since it was taken offline by unraid.

 

What should I do next?  I have not powered down or reset the server yet.  Should I power down, replace the sata cable, reseat the power, and boot back up and try running the syslog and smart report and smart test again?  I just don't want to power down too early until I get some advice, thank you!

Smart_Report_Before_Smart_Test.txt

syslogNov10-2012.zip

Link to post

Your disk is not responding in any way.

 

Stop the array, un-assign the drive that is not responding.

Power down, re-seat the POWER and DATA cables.

Power up, start the array with the disk un-assigned.

See if the drive then responds to smart report requests.  Make sure the device name did not change (if it does not respond, double check the device name, it might have changed from the last boot)

..  If it responds, great.  Stop the array, re-assign the drive, start the array, let unRAID reconstruct the disk.

 

  If  it does not respond, the disk make have died, or the cable failed...

  replace the cable (first) and if no success, try a different disk controller port, if still nothing, replace the disk.

Link to post

I wasn't able to unassign the disk, as soon as I stopped the array it showed as missing.

 

I powered down, re-seated the cables and powered back up. 

 

Still red ball, a * where temperature is, 0's for reads/writes/errors.

Array is showing as started.

 

I ran another syslog, attached

I ran a smart report, and it did complete this time, attached.

I then ran the short smart test, then ran the smart report again to include the results, attached.

 

I stopped the array, the drive does show up now, it does not show as missing.

 

SmartAfterTest.txt

SmartBeforeTest.txt

SyslogNov12_V2.txt

Link to post

I have re-built the drive and the drive is now green ball, but would like to ensure the drive isn't going bad and need replacing.

 

I have attached a new SMART report from after the re-build.

drive itself looks fine.  Likely it was a loose cable.
Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.