Jump to content

Compiling idle3 tools (the open-source linux WDIDLE3 alternative) in UnRaid 6.0


Recommended Posts

If you've been wanting to run WDIDLE3 on some of your WD harddrives, you may be interested to know there's a way to achieve the same result without needing to boot to DOS. Enter http://sourceforge.net/projects/idle3-tools/

 

First off, install unmenu and then the gcc-4.8.2-x86_64-1.txz package from pkg-manager.

 

Then, you will need to install the libmpc library:

cd /boot/packages
wget http://mirrors.slackware.com/slackware/slackware64-14.1/slackware64/l/libmpc-0.8.2-x86_64-2.txz
installpkg libmpc-0.8.2-x86_64-2.txz

 

Now, download the idle3 tools from the sourceforge link above, and un-tar to a location of your choice. Then

mkdir /boot/custom
cd /boot/custom
wget http://sourceforge.net/projects/idle3-tools/files/idle3-tools-0.9.1.tgz
tar -zxvf idle3-tools-0.9.1.tgz
cd idle3-tools-0.9.1
make

 

Watch magic happen.

 

I have not yet played with the tool, but I definitely ended up with a binary idle3ctl and though I would share while it is fresh in memory (tested on v6.0 beta 14).

 

 

*** Update ***

The tool worked on 5 out of 6 of my WD disks. It caused the 6th one to drop off the controller, but worked with that disk as well after moving to a different controller. Strangely, another WD disk on the same SASLP-MV8 controller worked fine. Anyways, remember to stop the array before playing with this. You will need to power off the server after anyways. I used idle3ctl -s138 /dev/sdX to set a 300s timeout. The 138 is a raw value. Check your current setting with idle3ctl -g105 /dev/sdX (use this after changing a raw value to see the actual timeout in seconds).

Link to comment
  • 9 months later...

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...