Jump to content

[SOLVED] Why did unraid come up configured like this? Normal?


Recommended Posts

Hi, guys. I need some advice.

 

Two days ago, everything was fine - I was running a Basic version of 5.0.6 with 3 disks. We had some thunderstorm activity then next day, and I noticed some issues with file playback, so i thought I would just clean shutdown and restart Unraid. When it came back up, I saw an entry in the log to run fsck on SDA which is the flash drive, I think - my array won't boot on that usb now. I was about to upgrade anyway, to unraid 6 beta 14. So, I prepared my usb, formatted it, unzipped the files onto it, copied the config files from the old stick to the new one, took it down to test - no boot - immediately knew I failed to do the make_bootable, so I did that. Attempt #2 booted...but no disk assignments. Realized that I also did not copy the share configs over to the share subfolder. Did powerdown and then copied the share configs over. Rebooted again. Still no disk assignments...so, I knew which one was parity - I assigned it. Will it screw things up if I guess wrong for data disk 1 and data disk 2?

 

The beta says Parity is Valid. Does that mean I guessed right? I have not yet started the array.

 

What do you think?

 

Thanks in advance

 

Unqualified (SuperChicken) Spectator.

 

Oh, yeah - the default for file system is XFS - It won't do anything to my ReiserFS disks, eh? Should I change to to RFS for now, just to be safe?

 

Link to comment

It sounds like you did not copy super.dat back, it's the one with the drive assignments.  You should be able to shut down, copy the file back, and reboot.

 

The default being XFS just means that new drives will default to being formatted with XFS, unless you change it for that drive.  There's no effect on existing drives, they all coexist fine.

Link to comment

And that was it.

Rob, you are "The MAN". ;D

 

I knew it was something I'd overlooked. I was trying to be so careful to not put anything on the new usb...that I left something vital out. Unraid is awesome stuff...it survives even a newb like me.

 

When the super.dat file was moved over, Unraid identified the drives correctly and that they were RFS. No worries. Time to check some parity, purchase my key, and do some testing. (Maybe not in that order).

 

Thanks again.

 

 

Link to comment

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...