Jump to content

Driver for my Dual-Port Ethernet seems to be missing


ChrisCalzolaio

Recommended Posts

Hello everybody,  :)

 

I am new to unRAID and this forum, so I read the "Need Help? Read me first" instruction!

So hopefully I've gathered all the neccesarry information!

 

The Symptom: I can't access the WebGUI after new installation

 

The Problem:

ifconfig -a

doesn't return any ethx devices (only: gre0, gretap0, ip_vti0, lo)

 

  • This led me to believe, that unRAID cannot use any of my Ethernet Ports, therefore does not obtain an IP and cannot be accessed through the web
  • lspci

    returned information about the Ethernet controller:

    06:00.0 (and .1) Ethernet Controller: Intel Corporation 80003ES2LAN Gigabit Ethernet Controller (Copper) (rev 01)


  • since they are listed there, but aren't in the managed network devices, there must be problem with the driver (is that assumption correct?), so:
  • I used
    lsmod

    , to list all the kernel modules which returned amongst others: e1000e

  • Quick research returned: http://www.intel.com/content/www/us/en/support/network-and-i-o/ethernet-products/000005480.html
  • it says there: "The Linux* e1000e driver supports PCI Express* Gigabit Network Connections except the 82575, 82576, 82580, and I350."
    my Ethernet Controller Chipset is: 82563EB (full hardware listet below
  • so I searched for the appropriate driver on the Intel HP and tried installing, which failed, because
    make

    is unavailable

  • then I found a topic in the unRAID wiki, on how to compile my own kernel, which I considered doing for a second  :o

 

My Questions:

 

  • Is the installed driver indeed incompatible with my hardware?
  • Do I have to compile a personal kernel in order to install the driver for my hardware?
  • And if so, is there any chance for a future support, despite the age of the hardware?
  • Is my hardware really that unique, to not have support natively?
  • Is there something entirely different I seem to be missing?

 

Attached you will find the syslog, which i gathered through

diagnostics

. It talks shortly about eth0 but I can't make sense of it really!

 

The Hardware:

 

MoBo:Supermicro X7DBE+

Processors: dual Xeon X5460

RAM: 32 Gb

Ethernet: Intel® (ESB2/Gilgal) 82563EB Dual-port Gigabit Ethernet Controller

Chipset: Intel® 5000P (Blackford) Chipset

 

note: Win Server 2012 has been running on this machine no trouble at all!

 

I would be really happy, to have this problem resolved!

Thanks guys!  :)

 

One final question: my display cuts of the bottom most one and a half lines, which get old pretty quickly  ;D anyone have an idea how to fox that? :D thanks!

tower-diagnostics-20160222-0933.zip

Link to comment

Your Intel dual NIC is supported by e1000e, and that driver loads correctly, but when it tries to initialize the chipsets, it reports errors, for both -

Feb 22 09:17:23 Tower kernel: e1000e: Intel® PRO/1000 Network Driver - 2.3.2-k

Feb 22 09:17:23 Tower kernel: e1000e: Copyright© 1999 - 2014 Intel Corporation.

Feb 22 09:17:23 Tower kernel: e1000e 0000:06:00.0: Interrupt Throttling Rate (ints/sec) set to dynamic conservative mode

...

Feb 22 09:17:23 Tower kernel: e1000e 0000:06:00.0: The NVM Checksum Is Not Valid

Feb 22 09:17:23 Tower kernel: e1000e: probe of 0000:06:00.0 failed with error -5

Feb 22 09:17:23 Tower kernel: e1000e 0000:06:00.1: Interrupt Throttling Rate (ints/sec) set to dynamic conservative mode

Feb 22 09:17:23 Tower kernel: e1000e 0000:06:00.1: The NVM Checksum Is Not Valid

...

Feb 22 09:17:23 Tower kernel: e1000e: probe of 0000:06:00.1 failed with error -5

...

Feb 22 09:17:26 Tower logger: /etc/rc.d/rc.inet1:  List of interfaces: 'eth0'

...

Feb 22 09:17:26 Tower logger: /etc/rc.d/rc.inet1:  eth0 interface does not exist (yet)

I did a little research online, found it's a not uncommon issue with a number of Intel NIC's.  It means your NIC EEPROM is corrupted.  Apparently, Windows just ignores the error, Linux does not.  Intel has a BootUtil tool that can fix the EEPROM.  Some users successfully repaired it that way.  Others deleted the NVM checksum test from the source code and recompiled.  Here are several links of interest -

  http://mynixworld.info/2012/12/05/e1000e-the-nvm-checksum-is-not-valid/

  http://askubuntu.com/questions/441420/how-to-get-around-nvm-checksum-error-pxe-e05-to-make-the-ethernet-work#

  https://thesorcerer.wordpress.com/2011/07/01/guide-intel-82573l-gigabit-ethernet-with-ubuntu-11-04-and-fix-pxe-e05/

  http://ubuntuforums.org/showthread.php?t=1738379

You might have a look at Hajo's steps in the Sorcerer link.

 

The monitor is set for "Console: colour VGA+ 80x25", and I didn't see anything that could affect it.  I change mine to 80x60, by adding "VGA=6" to the append line in syslinux.cfg.  That will give you more lines, not sure if it fixes your issue though.

Link to comment

Hey RobJ,

 

thank you soo much! It worked out!

 

It's amazing you picked up on that NIC configuration error!

I knew of that error before and had a suspicion it had something to do with it! I tried to fix it with a tool similar to what The Sorcerer01 is using, thought I had it resolved tho, because I didn't get the error message during boot anymore. That might have been, because I disabled the boot from LAN option in the BIOS in the same boot process as running the bootutil! So it turns out, I didn't resolve it the first time around!

 

I couldn't fix the display problem, and weirdly it also appeared when running DOS for the bootutil, but doesn't when running WIN Serv Datacenter with GUI. Since it works now tho, I really don't care about it for now!

 

Thank you again!

 

Chris

Link to comment

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...