Jump to content

connection refused during playback


Recommended Posts

Hello everyone. Been using unraid for some time now without any problems until today. I have looked at a lot of post but have yet to find a solution to my problem. It started after a power outage in my area. The ups shut the server down, I  booted the server back when the power was restored, and the playback on my osmc pi2 kodi install would stop during playback. Sometimes it would be 10 to 15 minutes, other times it would be less than a minuet after starting playback. This is configured to use SMB and I have tested all 3 versions with no luck. Done some digging around in my kodi logs and found errors with connection refused.

ERROR: Unable to open database: video107 [2003](Can't connect to MySQL server on '' (111 "Connection refused"))
ERROR: SMBDirectory->GetDirectory: Unable to open directory : 'smb://Tower/TVShows/Chicago%20Fire/Season%204' unix_err:'6f' error : 'Connection refused'

I tested playing a video from my Windows 10 desktop using MPC-HC player. I didn't have any issues playing from there. This prompted me to test a fresh install of Kodi, older versions of Kodi, an android box with Kodi installed, and finally a version of Kodi on my desktop. All ended up with the same issue. I tried several videos to make sure it was not any one video as well.


Puzzled I started poking around on the server and trying to come up with a good explanation as to why this started happening. It was working fine before the shutdown. I tried both private and public (current setting) with no luck. Created an new user and that didn't work either. Didn't really expect it to, but hey you never know. So I am at a loss as what the issue is, and not entirely sure it is with the unraid server, but I am looking at all angles. Hopefully someone can point me in the correct direction to fix this issue.


I also forgot to mention that I have tried restarting the server in safe mode with no luck, and here is the diagnostics log.




Link to comment

Wanted to give an update on this.

 I changed from smb to nfs and I still have the issue.


I have also noticed that one of my shares doesn't seem to take any security changes. The only way I can get the changes to take effect is if I read settings from another share.

Link to comment

Updated to latest version with no luck.


Tried backing up password and shadow files as one post suggested and it didn't fix it.


Looks like I'm all alone in trying to figure this out. So I guess I'm going to see if I can find some information on reinstalling without loosing the array, and possibly docker.

Link to comment


This topic is now archived and is closed to further replies.

  • Create New...