Jump to content

[Solved] Debian Network stopped working after editing VM


Recommended Posts

Wanted to share this as I spent some time fixing it this evening, my linux skills are not the best so it took a while.


I have a plex server running on Debian 9 in a VM on Unraid 6.5.3.


I stopped the VM, edited it and added an extra CPU core. Once started there was no network connection any more when I ran ifconfig (other than the local loopback) via VNC.


lspci - this showed the inteface card was there, chaning the type as other threads recommended didn't make a difference.

ip address show - this gave me the interface name (that took me the longest to track down)

I then edited /etc/network/interfaces and changed enp1s0 to match the new interface name in the 3 places shown below:


# The primary network interface
allow-hotplug enp1s0
iface enp1s0 inet dhcp

# This is an autoconfigured IPv6 interface
iface enp1s0 inet6 auto


After running the following (name to match the new interface name) I got networking back.

ifconfig enp1s0 up


I rebooted and everything was still fine. Hope this of use to people a similar issue :)

Link to comment


This topic is now archived and is closed to further replies.

  • Create New...