[solved] Starting Windows 10 VM fills syslog


3 posts in this topic Last Reply

Recommended Posts

This seems to fix the problem. VNC did not connect at first but rdp and splashtop did. VNC worked after I logged in once.




Windows 10 VM on Supermicro X11SPM-F with GeForce RTX 2080 SUPER appears to be working. VNC is not usable but splashtop works well. I passed the GeForce through using Syslinux configuration with "{append initrd=/bzroot} vfio-pci.ids=10de:1e81,10de:10f8,10de:1ad8,10de:1ad9" I installed newer nvidia drivers and chose the nvidia card as primary GPU. No ROM BIOS file is needed

Link to post

After further testing weirdness ensues. I rebooted in safe mode and back to normal mode. The BIND from vfio-pci.cfg is working correctly and i am successfully using the stock Syslinux configuration. I still needed the following three lines in the go file for the VM to startup and not fill the syslog:

#fix video for VM
echo 0 > /sys/class/vtconsole/vtcon0/bind
echo 0 > /sys/class/vtconsole/vtcon1/bind
echo efi-framebuffer.0 > /sys/bus/platform/drivers/efi-framebuffer/unbind




Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.