Jump to content
Elrith

Asus Hyper x16 NVME card & X10DRG-Q

2 posts in this topic Last Reply

Recommended Posts

Posted (edited)

Hello Gents,

 

I have recently purchased this Quad NVME card and I'm trying to set it all up with Unraid

The spec:

X10DRG-Q MB

8*16GB DDR4 2666 (running at 2133)

LSI 9211-4i

1*6TB HGST SAS

2*2TB Samsung SAS 

3*1TB Seagate SATA onboard

1*480G Intel SSD (cache)

1*WD BLUE NVME 500G

3*760P Intel NVME

Asus Hyper x16

Corsair RM1000X PSU

RTX 2080

Creative sound blaster Z

 

I've enabled bifurcation from x16 => x4x4x4x4

 

The problem:

The system is  booting up properly, I'm able to see 4 nvme drives in Unraid, happy days. I'm starting my array and then the whole server hangs. After this I'm restarting and the server hangs during the boot sequence inside the BIOS.

 

What I've tried:

3.1 and 3.1C bios

3xNVMES

I/O non posted prefetch enabled

Disabling as many devices as possible from the BIOS

Setting the Asus card PCIE port for UEFI

Booting unraid in Legacy/UEFI

Moving the card to a different slot

 

What worked partially but hinders me from seeing all 4 drives:

Not enabling bifurcation allows me to see 1 NVME drive but the system is stable.

 

IPMI is reporting the following error whenever the hang occurs:

#0x00 ProcessorConfiguration Error (DMI) - Assertion

 

The system has always been stable, no crashes or freezes. 

I don't think I'm running out of PCI lanes, i thought about this possibility.

 

At the same time writing this I'm writing an email to supermicro. 

I hope to pick your brains and see what are your suggestions. 

 

Thank you for taking the time to go through this post.

 

 

 

 

 

Edited by Elrith

Share this post


Link to post

Fixed*

The WD blue NVME drive was the one at fault. The array is working fine now with the Intel ones.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.