SWAG, SpaceInvaderOne, website server


MaxTek

1 post in this topic Last Reply

Recommended Posts

Hi every one,

 

I've got great time with my unraid server since 6 months.

I've followed SpaceInvaderOne in configuration: SWAG, Jitsi, Radarr, Sonarr,.....

 

Now, I'd love to host my websites (multi domains) on my unraid server.

 

I started with that : https://technicalramblings.com/blog/how-to-set-up-a-wordpress-site-with-letsencrypt-and-mariadb-on-unraid/

 

What I want: Wordpress.MyDomainName.com pointing on a wordpress site.

 

What I get now: Wordpress.MydomainName.com pointing on the default swag webpage.

       If I'm doing Wordpress.MyDomainName.com/wordpress, I've got my wordpress site.

 

What I did:

- Add Wordpress.MyDomainName.com in Subdomain(s) Swag Docker

- Copy/rename the "default" files in /appdata/swag/nginx/site-conf/. I've got now wordpress.mydomainname.com.conf (the copy of "default").

 

I've made some few editions, and start again my swag docker.

 

The error is:

nginx: [emerg] the same path name "/var/lib/nginx/cache" used in /config/nginx/site-confs/default:153 and in /config/nginx/site-confs/wordpress.mydomainname.com.conf:153

 

I'm a little bit confused....

What am I doing wrong ?

 

Here is my wordpress.mydomainname.com.conf:

## Version 2020/05/23 - Changelog: https://github.com/linuxserver/docker-swag/commits/master/root/defaults/default

# redirect all traffic to https
server {
        listen 80;
        listen [::]:80;
        server_name wordpress.mydomain.com;
        return 301 https://wordpress.mydomain.com$request_uri;
}

# main server block
server {
        listen 443 ssl http2;
        listen [::]:443 ssl http2;

        root /config/www/wordpress;
        index index.html index.htm index.php;

        server_name wordpress.mydomain.com;

        # enable subfolder method reverse proxy confs
        include /config/nginx/proxy-confs/*.subfolder.conf;

        # all ssl related config moved to ssl.conf
        include /config/nginx/ssl.conf;

        # enable for ldap auth
        #include /config/nginx/ldap.conf;

        # enable for Authelia
        #include /config/nginx/authelia-server.conf;

        # enable for geo blocking
        # See /config/nginx/geoip2.conf for more information.
        #if ($allowed_country = no) {
        #return 444;
        #}

        client_max_body_size 0;

        location / {
                try_files $uri $uri/ /index.html /index.php?$args =404;
        }

        location ~ \.php$ {
                fastcgi_split_path_info ^(.+\.php)(/.+)$;
                fastcgi_pass 127.0.0.1:9000;
                fastcgi_index index.php;
                include /etc/nginx/fastcgi_params;
        }


}

# enable subdomain method reverse proxy confs
include /config/nginx/proxy-confs/*.subdomain.conf;
# enable proxy cache for auth
proxy_cache_path cache/ keys_zone=auth_cache:10m;

 

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.