Jump to content
  • [6.10-rc4] Single M.2 NVMe disappears out of sudden, shown with weird label in /dev/disk/by-id


    hawihoney
    • Minor

    On my Supermicro X12SCA-F motherboard I used two M.2 NVMe 1TB "Samsung 970 EVO Plus" disks since nearly a year. Both disks were single disk pools each. Today one of the disks disappeared. Even after a reboot only one disk came up. The missing disk is not offered on the Main page and is not shown in the System Devices list (Tools page). But I think that this disk is shown with weird values in /dev/disk/by-id:

     

    476 0 lrwxrwxrwx 1 root root   13 Mar 30 14:32 nvme-Samsung_SSD_970_EVO_Plus_1TB_S4EWNZFN818010Z -> ../../nvme0n1
    479 0 lrwxrwxrwx 1 root root   15 Mar 30 14:32 nvme-Samsung_SSD_970_EVO_Plus_1TB_S4EWNZFN818010Z-part1 -> ../../nvme0n1p1
    477 0 lrwxrwxrwx 1 root root   13 Mar 30 14:32 nvme-eui.0025385801adb6b8 -> ../../nvme0n1
    480 0 lrwxrwxrwx 1 root root   15 Mar 30 14:32 nvme-eui.0025385801adb6b8-part1 -> ../../nvme0n1p1
    

     

    Any idea what these two additional lines mean. Is it all the same disk or are these two disks? And if these are two disks, how come that they share the same identifier? Any help is highly appreciated.

     

    Diagnostics attached.

     

    Thanks a lot.

     

    tower-diagnostics-20220330-1518.zip




    User Feedback

    Recommended Comments

    Only one NVMe device is being detected by Linux, not sure what the other device is about, but it's the same one, you can see the serial number on the SMART report.

     

    Try power cycling the server or check if the other device is being detected in the BIOS.

    • Thanks 1
    Link to comment


    Join the conversation

    You can post now and register later. If you have an account, sign in now to post with your account.
    Note: Your post will require moderator approval before it will be visible.

    Guest
    Add a comment...

    ×   Pasted as rich text.   Restore formatting

      Only 75 emoji are allowed.

    ×   Your link has been automatically embedded.   Display as a link instead

    ×   Your previous content has been restored.   Clear editor

    ×   You cannot paste images directly. Upload or insert images from URL.


  • Status Definitions

     

    Open = Under consideration.

     

    Solved = The issue has been resolved.

     

    Solved version = The issue has been resolved in the indicated release version.

     

    Closed = Feedback or opinion better posted on our forum for discussion. Also for reports we cannot reproduce or need more information. In this case just add a comment and we will review it again.

     

    Retest = Please retest in latest release.


    Priority Definitions

     

    Minor = Something not working correctly.

     

    Urgent = Server crash, data loss, or other showstopper.

     

    Annoyance = Doesn't affect functionality but should be fixed.

     

    Other = Announcement or other non-issue.

×
×
  • Create New...