• 6.10.0-rc4 (and rc3) stale configuration on first reboot, subsequent reboots OK

    • Minor

    Had this problem with RC3 and RC4, where the first reboot after update results in a "stale configuration" when restarted, so the array never starts (only offers reboot and shutdown buttons on the UI).


    Fortunately on second reboot it seems to work OK.... But why?  Had this issue on RC3, but forgot to capture a diagnostic before I rebooted, so when it happened this time, I remembered, and here it is!




    User Feedback

    Recommended Comments

    Just a thought if this helps track it down - at one point I had 18 array drives assigned, but there were a bunch of old, slow, small ones that were empty which I later decided to take out through "new configuration", so slots 13,14,15 and 18 showed up on the array as "unassigned" (which is proper), but it was showing "array of 20 devices" on the first reboot (stale configuration), but when it rebooted, the "unassigned" slots were gone and the list of array drives shows 2 x parity, then 1-12, skips to 16 and 17 and correctly shows "Array of sixteen devices" at the bottom.


    When I did the new configuration, I re-assigned the drives using their original array numbers, rather than collapsing them down to sixteen, which left unassigned gaps in the array layout (13,14,15,18), but I figured that was still safe.

    Link to comment

    Even more info... When the array mounts, I get a prompt from my browser:


    "To display this page, Firefox must send information that will repeat any action (such as a search or order confirmation) that was performed earlier".


    If I click Resend, the array fails to mount, with a "stale configuration" error.  If I click "Cancel", everything mounts properly.


    Maybe just a HTML bug?

    unraid error.jpg

    Edited by dgriff
    Link to comment

    Thanks for the report.  This is very odd which we can't replicate at the moment.

    The 'stale configuration' message is resulting from clicking Resend - I think what's happening is, after rebooting, once logged in you click the Start button and it looks like everything starts normally.  Then the above message appears in browser.  If you click Resend then it will POST the 'cmdStart' command but since the array is already started, this command won't execute and instead it generates the 'stale configuration' message.


    There are other reports of similar:



    So we will have to keep a watch out for this and try and figure out what are the conditions where this is happening.  If you see this again, best thing to do is Cancel.

    Link to comment
    43 minutes ago, ljm42 said:

    Can you confirm whether or not this is still happening in Unraid 6.10.1 ?

    Seems to be acting the same.  I think it may be Firefox related (even with all addons disabled).  I don't get the same message in Chrome or Safari.

    • Like 1
    Link to comment

    I know this is ancient but I'd like to report this is still a problem with Firefox in 6.11.5.


    A quick addition: This doesn't occur when using the remote access via Unraid's tunnel.

    Edited by Flatfire
    Link to comment

    Join the conversation

    You can post now and register later. If you have an account, sign in now to post with your account.
    Note: Your post will require moderator approval before it will be visible.

    Add a comment...

    ×   Pasted as rich text.   Restore formatting

      Only 75 emoji are allowed.

    ×   Your link has been automatically embedded.   Display as a link instead

    ×   Your previous content has been restored.   Clear editor

    ×   You cannot paste images directly. Upload or insert images from URL.

  • Status Definitions


    Open = Under consideration.


    Solved = The issue has been resolved.


    Solved version = The issue has been resolved in the indicated release version.


    Closed = Feedback or opinion better posted on our forum for discussion. Also for reports we cannot reproduce or need more information. In this case just add a comment and we will review it again.


    Retest = Please retest in latest release.

    Priority Definitions


    Minor = Something not working correctly.


    Urgent = Server crash, data loss, or other showstopper.


    Annoyance = Doesn't affect functionality but should be fixed.


    Other = Announcement or other non-issue.