• 6.9.0 beta 35 Dashboard ui broken for docker & Vm's


    turnipisum
    • Solved Minor

    The ui is broken on the dashboard for docker & VM's on chrome browser.

    Does nothing when you click on icon's and it's only showing 1 vm of the 3 i have running. All fine if you go into docker tab and vm tab all works as it should.

    • Like 3
    • Thanks 1


    User Feedback

    Recommended Comments



    It's working for me on my server (no VMs though on it).  Do you happen to have one of the plugins installed (eg: Docker Folders) that modifies the dashboard?

    Link to comment
    Share on other sites

    Like Squid, my Dashboard is fully functional. Not using VMs either.

    It will be difficult to help you diagnose further than the question above with so little information.

     

    You should share your diagnostics in your next post (Tools/Diagnostics).

    Link to comment
    Share on other sites

    stop all running VMs and then you start them again.

     

    update:

    it is showing correctly while only one vm is running. 

    Edited by emrepolat7
    update
    Link to comment
    Share on other sites

    I only have one VM and this doesn't show at all on the dashboard as well as the same issue of dockers only displaying in 2 columns

    Link to comment
    Share on other sites
    15 minutes ago, Tungmeister said:

    I only have one VM and this doesn't show at all on the dashboard as well as the same issue of dockers only displaying in 2 columns

    try to stop vm & restart

    Edited by emrepolat7
    Link to comment
    Share on other sites

    I have the same problem as OP, 3 vms installed, only 1 showing on dashboard, cannot click these for the menu either.

    image.png.2931615d2f05f9ab0c78c446708064f7.png

    All 3 showing in VM tab:

    image.png.8910651dac72e0f9b85e67b0891352e4.png

     

    The Docker list looks different from beta30 (only 2 rows), and nothing happens when I click on the icons:

    image.png.b137288c97c053e2a17160ff847509fe.png

    But it works fine in the Docker tab:

    image.png.05d6ba23407e80df0876234a2771445a.png

    Edited by Raspen
    added info
    Link to comment
    Share on other sites

    All my vm's are running VNC, my GPU is dedicated to Plex and Jellyfin, but as you say, there is some issue with the VNC, because if I start my stopped VM, it goes from VNC:Auto to VNC:5902, and disappears from the dashboard.

     

    And when I stopped all running VM's it reverted to normal:

    image.png.b6c06d1bffb3295e2ea2d8e2b1fb05cc.png

    • Thanks 1
    Link to comment
    Share on other sites

    If you collapse the VM section by clicking on the ^ icon next to the gear at the far right, the rest of the pane is displayed correctly, suggesting that the problem is with the code that displays the VMs, rather than the code that displays the Docker containers and explaining why people who have no VMs don't see the problem.

     

    EDIT: The above observation was made using the Chromium browser. With Firefox the Docker containers display normally (three columns) and just the VM area is affected, missing items.

     

    Edited by John_M
    Different browsers behave differently
    Link to comment
    Share on other sites

    Hello, I can confirm that I have just noticed exactly the same problem. I run on the same version of UNRAID. it is not blocking but just disturbing. thanks in advance

    Link to comment
    Share on other sites

    Agreed!

     

    The problem seems to lie with the VM part of the Dashboard, specifically the VNC portion of it.

     

    Exhibited the same characteristics as @John_M with Chrome, and when I ran it in Firefox, docker is normal, but VM's are only showing stopped (not the ones with VNC enabled)

     

    Edit:

    But, the Docker section only looks ok when minimizing the VM's and in Firefox, still cannot click anything to get up the Docker menus.

    Edited by Raspen
    Link to comment
    Share on other sites
    2 hours ago, Raspen said:

    But, the Docker section only looks ok when minimizing the VM's and in Firefox, still cannot click anything to get up the Docker menus.

    Yes, agreed. Mouse clicks have no effect.

     

    Link to comment
    Share on other sites

    Same problem here.

     

    On the Dashboard, the Virtual Machines section is closed, and opening it does not show the VMs, as it used to do.

     

    And the Docker Containers icons don't react anymore when clicked on the Dashboard.

     

    It all works when accessed from the Docker or VMs tab.

     

    unraid-diagnostics-20201115-1532.zip

    Link to comment
    Share on other sites

    It didn't last. On restarting VM's they disappeared from the dashboard 🤷‍♂️


     

    Quote

     

    I had the same issue. I was running the Unraid nVidia build.

     

    From what I can see, the new beta35 version has the nVidia driver included: https://unraid.net/blog/unraid-6-9-beta35

     

    Anyway, installing @ich777's plugin seems to have solved it. Make sure to disable and then re-enable Docker. I also disabled and re-enabled VMs.

     

    I'm just a noob, so I can't really help further than this, hopefully this solves the issue for people 🤞


     

     

    Edited by Scooshie
    Link to comment
    Share on other sites

    Just a further update, I have two VM's:

     

    • Windows 10 with an Asus 2070 Super GPU pass-through 
    • Linux running Home Assistant with VNC.

     

    If I just start the Windows 10 VM, everything works. When I start the Linux VM running VNC, then everything disappears from the VM section on the dashboard. It doesn't matter if the Windows VM is running, as soon as I start the Linux VM, they disappear from the dashboard.

     

    As people have said, the VM's run fine, it is only a bug in the VM dashboard section.

    Link to comment
    Share on other sites

    I'm also here seeing the exact same thing on 6.9.0 beta 35. I only have 2 VM's that both have VNC graphics. No matter what (none running, only one running or both running) the VM Dashboard section is empty and when I open up the view with the down arrow the whole middle column distorts (and Dockers only show in 2 columns). Closing the VM view clicking ^ makes display normal (and Dockers showing in 3 columns).

    Link to comment
    Share on other sites

    Something weird is happening to my server, i did go back to beta 31 by manuel overide of the flash files for an unrelated issue, and the problem is still there...

    Link to comment
    Share on other sites

    Partial workaround:

     

    Go to Settings - Display Settings and change "Show Dashboard apps" to "Docker only". Then Dockers on Dashboard work but you will have to go to VMS page to work with your VMs.

    • Thanks 3
    Link to comment
    Share on other sites
    51 minutes ago, trurl said:

    Partial workaround:

    Yes, that works. Unlike collapsing the VM section, this allows you to click on the Docker icons.

     

    Link to comment
    Share on other sites



    Join the conversation

    You can post now and register later. If you have an account, sign in now to post with your account.
    Note: Your post will require moderator approval before it will be visible.

    Guest
    Add a comment...

    ×   Pasted as rich text.   Restore formatting

      Only 75 emoji are allowed.

    ×   Your link has been automatically embedded.   Display as a link instead

    ×   Your previous content has been restored.   Clear editor

    ×   You cannot paste images directly. Upload or insert images from URL.


  • Status Definitions

     

    Open = Under consideration.

     

    Solved = The issue has been resolved.

     

    Solved version = The issue has been resolved in the indicated release version.

     

    Closed = Feedback or opinion better posted on our forum for discussion. Also for reports we cannot reproduce or need more information. In this case just add a comment and we will review it again.

     

    Retest = Please retest in latest release.


    Priority Definitions

     

    Minor = Something not working correctly.

     

    Urgent = Server crash, data loss, or other showstopper.

     

    Annoyance = Doesn't affect functionality but should be fixed.

     

    Other = Announcement or other non-issue.