Jump to content
  • [6.12] SMB not working on network interfaces that have not been added via docker

    • Minor

    On 6.12 I have to configure my network adapters in Settings/NetworkSettings.


    I have added the wg2 and the tun5 interface of my wireguard and openvpn instance to the extra interfaces.

    I can reach the WebUI via both of them, including SSH.

    In addition, I also have added my zerotier interface. The ZT instance is running inside of docker, whereas OpenVPN and wireguard run on bare metal.


    However, I cannot access any SMB shares.


    If I inspect the smb.conf and smb_names.conf file I can see that it binds to the local interface, and my wireguard and openvpn interface.

    However, the shares are still not available.


    However, I have a ZeroTier docker container. Through this interface I can magically access the WebUI, SMB and SSH.

    It doesn't make sense at all to me.


    For now I'll have to downgrade because I can't really afford to have the server inaccessible, but I wanted to report this nonetheless.

    Other people reported they can't access the web UI at all, for me it's just SMB on interfaces that do NOT run in docker.


    I had the window with the smb configuration still open:

    This is what unraid configured (zerotier was not enabled at this time because the docker engine had crashed).


    the 194 interface is wireguard, the 10.11.12 is openvpn.


    root@Tower:/etc/samba# cat smb.conf
            # configurable identification
            include = /etc/samba/smb-names.conf
            # log stuff only to syslog
            logging = syslog@0
            # recycle bin parameters
            syslog = 0
            logging = 0
            max log size = 10000
            # we don't do printers
            show add printer wizard = No
            disable spoolss = Yes
            load printers = No
            printing = bsd
            printcap name = /dev/null
            # disable aio by default
            aio read size = 0
            aio write size = 0
            # misc.
            invalid users = root
            unix extensions = No
            wide links = Yes
            use sendfile = Yes
            # ease upgrades from Samba 3.6
            acl allow execute always = Yes
            # permit NTLMv1 authentication
            ntlm auth = Yes
            # default global fruit settings:
            #fruit:aapl = Yes
            #fruit:nfs_aces = Yes
            fruit:nfs_aces = No
            #fruit:copyfile = No
            #fruit:model = MacSamba
            # hook for user-defined samba config
            include = /boot/config/smb-extra.conf
            # hook for unassigned devices shares
            include = /etc/samba/smb-unassigned.conf
            # auto-configured shares
            include = /etc/samba/smb-shares.conf
    root@Tower:/etc/samba# cat smb-names.conf
    # Generated names
    netbios name = Tower
    server string = Media server
    hide dot files = no
    server multi channel support = yes
    max open files = 40960
    multicast dns register = No
    disable netbios = No
    server min protocol = NT1
    local master = yes
    os level = 100
    security = USER
    workgroup = WORKGROUP
    map to guest = Bad User
    passdb backend = smbpasswd
    null passwords = Yes
    idmap config * : backend = tdb
    idmap config * : range = 3000-7999
    create mask = 0777
    directory mask = 0777
    bind interfaces only = yes
    interfaces = fd94::5
    root@Tower:/etc/samba# cat smb-names.conf


    User Feedback

    Recommended Comments

    In the current implementation we do a 'soft' update to let SMB reread the configuration, this unfortunately does not change the listening interfaces of SMB (eventhough the config is updated).


    In the next release this will be fixed.


    • Like 1
    Link to comment

    Join the conversation

    You can post now and register later. If you have an account, sign in now to post with your account.
    Note: Your post will require moderator approval before it will be visible.

    Add a comment...

    ×   Pasted as rich text.   Restore formatting

      Only 75 emoji are allowed.

    ×   Your link has been automatically embedded.   Display as a link instead

    ×   Your previous content has been restored.   Clear editor

    ×   You cannot paste images directly. Upload or insert images from URL.

  • Status Definitions


    Open = Under consideration.


    Solved = The issue has been resolved.


    Solved version = The issue has been resolved in the indicated release version.


    Closed = Feedback or opinion better posted on our forum for discussion. Also for reports we cannot reproduce or need more information. In this case just add a comment and we will review it again.


    Retest = Please retest in latest release.

    Priority Definitions


    Minor = Something not working correctly.


    Urgent = Server crash, data loss, or other showstopper.


    Annoyance = Doesn't affect functionality but should be fixed.


    Other = Announcement or other non-issue.

  • Create New...