Jump to content
  • [6.12] Upgrade to 6.12 breaks access when using Tailscale

    • Urgent


    - I am using Tailscale to access my Unraid server (UI, SMB, SSH, everything)

    - I have no access to real hardware. I am in a different country.

    - I have upgraded to 6.12.

    - After reboot I lost access to my Unraid server. I don't know how to get access back.




    After I went to Unraid UI, I saw that there is a new version and I decided to upgrade as I am doing often.

    After server reboot I could not access my server anymore.


    I have started debugging...


    I saw that server is still in Unraid network and I can ping it. But 80, 443, 22 ports and SMB were not accesible. That was weird.

    I used nmap to scan all open ports and saw that 23 (telnet) port is open.

    I have installed telnet on my MacOS and accessed terminal through 23 port.


    Running ss -tpln showed that ssh and http servers are listening, but seems they were listening on a wrong IP.


    I then went and read Change Log for new Unraid version (6.12) and read about networking changes and followed provided link.

    Unfortunately all these links tell you how to fix Tailscale if you have access to WebUI, which I do not. And I cannot go and connect monitor to my Unraid server or something as I am in a different country.


    I believe that this is a bug as an upgrade should not break existing setups.


    And I need help with this problem. I do not have access to WebUI. How do I do required steps through terminal?


    Thank you.

    • Like 1

    User Feedback

    Recommended Comments

    i have no clue what I'm doing wrong.


    My access randomly breaks, and even if I get WebUI access with wireguard/tailscale, I can't get SMB shares to work.

    Removing and re-adding the interface sometimes restores WebUI access, sometimes it breaks everything and I have to reboot the server.


    Link to comment
    2 hours ago, bonienl said:

    Use the stable version 6.12.1

    And read the release notes about using tailscale.



    6.12.1 didnt work, thats what I upgraded it to.

    Link to comment

    So for anyone reading, as this is #1 in google:


    To use the Tailscale or Zerotier interface, it is required to add the interface name or IP address of the communication to the list of included listening interfaces.

    Important: It is imperative that Tailscale or Zerotier container is running before the interface is added to the list.


    further Info: https://forums.unraid.net/bug-reports/prereleases/unraid-os-version-6120-rc7-available-r2427/?tab=comments#comment-24235

    Edited by 012315
    Link to comment
    On 6/22/2023 at 1:24 AM, TBT said:

    That method does not help for SMB.


    Same for me. Adding the tailscale0 interface enables WebUI Access over the Tailscale IP again but neither SMB nor NFS over the Tailscale IP!

    Link to comment
    45 minutes ago, bonienl said:

    You need to disable netbios to run smb over tailscale.


    in Version 6.11.5 it works with netbios enabled...


    Is this a bug in the new release?


    EDIT: Tried out, still not working (SMB and NFS)

    Edited by CaptainIntel
    Link to comment

    Also for me, with Zerotier: not working with Netbios disabled on the ZT interface. And indeed it worked unchanged with Netbios on on 6.11.5.

    • Upvote 1
    Link to comment

    You need to disable netbios under SMB settings.


    Here is my tailscale connection to my server 1



    And my zerotier connection to my server 2


    • Upvote 1
    Link to comment
    On 6/24/2023 at 11:33 PM, bonienl said:

    You need to disable netbios under SMB settings.


    Here is my tailscale connection to my server 1



    And my zerotier connection to my server 2


    Thank you for providing the working connections. So it should be sth. else which will cause the issue...



    Link to comment

    Hello everyone, I installed 6.12.1, modified go file adding instructions for reload_services, but I'm not able to connect  using tailscale's ip address.
    For accessing by tailscale ip address I need manually to remove ad re-add tailscale0 to listening interfaces.
    Where am I wrong?


    Link to comment
    On 6/24/2023 at 5:33 PM, bonienl said:

    You need to disable netbios under SMB settings.


    Here is my tailscale connection to my server 1



    And my zerotier connection to my server 2



    Thanks disabling Netbiis fixed my Tailscale Connection.

    Link to comment

    Join the conversation

    You can post now and register later. If you have an account, sign in now to post with your account.
    Note: Your post will require moderator approval before it will be visible.

    Add a comment...

    ×   Pasted as rich text.   Restore formatting

      Only 75 emoji are allowed.

    ×   Your link has been automatically embedded.   Display as a link instead

    ×   Your previous content has been restored.   Clear editor

    ×   You cannot paste images directly. Upload or insert images from URL.

  • Status Definitions


    Open = Under consideration.


    Solved = The issue has been resolved.


    Solved version = The issue has been resolved in the indicated release version.


    Closed = Feedback or opinion better posted on our forum for discussion. Also for reports we cannot reproduce or need more information. In this case just add a comment and we will review it again.


    Retest = Please retest in latest release.

    Priority Definitions


    Minor = Something not working correctly.


    Urgent = Server crash, data loss, or other showstopper.


    Annoyance = Doesn't affect functionality but should be fixed.


    Other = Announcement or other non-issue.

  • Create New...