Jump to content
  • [6.12.4] SMB copy/move between two Unraid servers stalls and crashes


    hawihoney
    • Minor

    This is a follow up of the following thread. In the meantime I tried to work around this situation without success. This worked 100% in 6.11.5. With 6.12.4 it crashes all the time:

     

     

    This is bare bone Unraid server with two DAS (direct attached storage) boxes (look at my avatar). Each DAS has it's own license stick in the bare bone. Each DAS is an Unraid VM driven with it's own HBA (LSI 9300-8e) in the bare bone server. In fact it's one big server with two virtualized servers running on the bare bone server. This system is running since 3 or 4 years 365/7/24 without any problem. The problems started with 6.12.4.

     

    With the help of the Unassigned Devices plugin I mount each disk (!!!) of the remote boxes to all other servers (SMB). Because of the mass of df calls whenever the main page of Unraids GUI is open I changed that in the meantime. I only mount when I need to move something between boxes. I use MC (Midnight Commander) to copy/move.

     

    Beginning with 6.12.4 (coming from 6.11.5) a copy or a move between these boxes stalls and crashes later. In fact I can no longer copy/move files between the boxes.

     

    The only things I changed between 6.11.5 and 6.12.4 is to apply these three MACVLAN workarounds to all boxes:

     

    Enable bonding=yes

    Enable bridging=no

    Host access to custom networks=enabled

     

    Currently I'm totally lost. I doubt that this is a Unassigned Devices problem (I thought so at first) because I can mount manually and see the same bad result then. There must be something wrong with SMB or something below SMB in the stack.

     

    Diagnostics are attached. Here are some screnshots and outputs I can see:

     

    image.png.f66655ceb2a8405c01e1be7f5b822e9d.png

     

    Oct  5 09:28:57 TowerVM02 smbd[23615]: [2023/10/05 09:28:57.795965,  0] ../../source3/smbd/smb2_read.c:265(smb2_sendfile_send_data)
    Oct  5 09:28:57 TowerVM02 smbd[23615]:   smb2_sendfile_send_data: sendfile failed for file ******** (Connection reset by peer) for client ptr=0x5591252176f0,id=0,addr=ipv4:192.168.178.101:44356. Terminating

     

    Oct  5 09:40:05 TowerVM02 kernel: CIFS: VFS: \\192.168.178.101 sends on sock 00000000d6ef5cb3 stuck for 15 seconds
    Oct  5 09:40:05 TowerVM02 kernel: CIFS: VFS: \\192.168.178.101 Error -11 sending data on socket to server
    Oct  5 09:41:15 TowerVM02 kernel: CIFS: VFS: \\192.168.178.101 sends on sock 00000000b9770a51 stuck for 15 seconds
    Oct  5 09:41:15 TowerVM02 kernel: CIFS: VFS: \\192.168.178.101 Error -11 sending data on socket to server

     

    It's mostly if I copy/move between the two DAS boxes (VMs). If I use the bare bone server to copy from DAS box 1 to the other DAS box 2 instead it works if there's no huge file to copy. So I guess it's a SMB memory problem because the bare bone holds 128 GB and the DAS boxes hold 16 GB each. But this is only a guess.

     

    I need to repeat. That worked up until 6.11.5 without one single problem.

     

    Thanks in advance.

     

     

    ***EDIT1*** I just tried to move a folder from one DAS box to the other DAS box with Dynamix file manager. Same bad result. One of my ideas was that MC might have a problem, but this seems wrong. Using Dynamix file manager shows another problem. I can force stop a running MC in it's Putty session but I can't stop a running Dynamix file manager job - at least I didn't find a way.

     

     

    towervm01-diagnostics-20231005-1015.zip towervm02-diagnostics-20231005-1015.zip tower-diagnostics-20231005-1015.zip




    User Feedback

    Recommended Comments

    There are no comments to display.



    Join the conversation

    You can post now and register later. If you have an account, sign in now to post with your account.
    Note: Your post will require moderator approval before it will be visible.

    Guest
    Add a comment...

    ×   Pasted as rich text.   Restore formatting

      Only 75 emoji are allowed.

    ×   Your link has been automatically embedded.   Display as a link instead

    ×   Your previous content has been restored.   Clear editor

    ×   You cannot paste images directly. Upload or insert images from URL.


  • Status Definitions

     

    Open = Under consideration.

     

    Solved = The issue has been resolved.

     

    Solved version = The issue has been resolved in the indicated release version.

     

    Closed = Feedback or opinion better posted on our forum for discussion. Also for reports we cannot reproduce or need more information. In this case just add a comment and we will review it again.

     

    Retest = Please retest in latest release.


    Priority Definitions

     

    Minor = Something not working correctly.

     

    Urgent = Server crash, data loss, or other showstopper.

     

    Annoyance = Doesn't affect functionality but should be fixed.

     

    Other = Announcement or other non-issue.

×
×
  • Create New...