Jump to content
  • 6.12.4 Time Machine Shares Not Working


    James Miller
    • Minor

    Hi,

     

    I’m very new to Unraid, and this is my first post. 
     

    I’ve been using the trial but I’ve not been able to get Time Machine to work. From the Googling and reading the forums, this last appears to have worked around version 6.9.x.

     

    From what I can see so far the issues included:

     

    1) when you mark a share as exportable with Time Machine, it doesn’t appear to add the option to the samba config for that share. If I manually add “fruit:time machine = yes” to the config and restart samba, then if I manually connect the share at least OSX sees it as a Time Machine capable volume. 
     

    2) the Time Machine share isn’t advertised. If I manually edit the avahi conf and add a service for the TimeMachine share it becomes visible. 
     

    I suspect part of the issue is while WebUI is exposing settings, they don’t appear to be writing the required samba or avahi config for the backend services.

     

    What confuses me is it looks like this all worked back on 6.9.x, but doesn’t appear to have for a while. The first version I’ve tried is 6.12.4, so surprised this appears to have been broken for a while. 
     

    Am I missing something?

     

    I’d like to move from the trial to paid, but this is one of the main things I want this for (to move from an old Time Capsule).




    User Feedback

    Recommended Comments

    I found with 6.12.4 and later no problems with TimeMachine Shares being picked up.

     

    However what I did find was that Ventura 13.6+ (and Sonoma) now don't recognize the share as a TM destination unless you specify a Volume Size Limit in the share settings.  Leaving at the default (no limit) and the Mac won't recognize it.

    Link to comment

    Hi,

     

    Thanks for the quick response. I’m running 6.12.4, but it’s not working for me. My OSX instances are Monterey and Big Sur, and neither sees the disks, nor if I manually Mount works. 
     

    The below are screen shots on the WebUI config screen, and the SMB and AVAHI config files it’s generating. 

    IMG_1325.jpeg

    IMG_1326.jpeg

    IMG_1327.jpeg

    Link to comment


    Join the conversation

    You can post now and register later. If you have an account, sign in now to post with your account.
    Note: Your post will require moderator approval before it will be visible.

    Guest
    Add a comment...

    ×   Pasted as rich text.   Restore formatting

      Only 75 emoji are allowed.

    ×   Your link has been automatically embedded.   Display as a link instead

    ×   Your previous content has been restored.   Clear editor

    ×   You cannot paste images directly. Upload or insert images from URL.


  • Status Definitions

     

    Open = Under consideration.

     

    Solved = The issue has been resolved.

     

    Solved version = The issue has been resolved in the indicated release version.

     

    Closed = Feedback or opinion better posted on our forum for discussion. Also for reports we cannot reproduce or need more information. In this case just add a comment and we will review it again.

     

    Retest = Please retest in latest release.


    Priority Definitions

     

    Minor = Something not working correctly.

     

    Urgent = Server crash, data loss, or other showstopper.

     

    Annoyance = Doesn't affect functionality but should be fixed.

     

    Other = Announcement or other non-issue.

×
×
  • Create New...