Jump to content
  • [6.12.4] (VM) Libvirt service failure (after update)

    • Minor

    Logged in today as its been the first time ive been free of non-work nonsense.

    Shut down all my VM's, did the update from 6.12.3 to 6.12.4.

    Upon reboot I went to the VM tab to start my VM's back up and am greeted with:

    "Libvirt Service failed to start."


    In logs I see:

    Oct 8 17:11:24 X root: /usr/sbin/libvirtd: error: Unable to initialize network sockets. Check /var/log/messages or run without --daemon for more info.


    2023-10-08 22:11:24.912+0000: 13999: error : virNetSocketNewListenUNIX:510 : Failed to bind socket to '/run/libvirt/libvirt-sock': Address already in use


    Nothing has changed for the past few months, nothing network related seems incorrect.


    User Feedback

    Recommended Comments

    Hrm, for the first time I can recall, the rollback didnt work either and has currently bricked my unraid.

    Did make sure bridging was enabled per release docs (but I don't think that would cause it to just keel over)
    Dies after "loading /bzroot... ok"

    Same message for the other boot options, though you do get "loading /bzroot -gui ...ok" for the GUI ones


    Link to comment

    Went through logs as best I could hardware side (iLO/BIOS), nothing there.

    Memtest passed a few cycles not that I expected it to fail


    System is booted into a Linux Live environment (not a linux user myself, but works faster to get at data since im remote at the moment), so before I nuke if anyone has anything they want to check or a recommended fix, im all ears* since I can see the USB Flash drive (thus all the data on it) and it also reports healthy.


    *After some sleep of course!

    Edited by Hammerfest
    Link to comment

    Disclaimer: I posted on Sunday, its only Monday, the following is said with that understanding of not a lot of time has passed.


    Not seeing anything I went ahead and made a backup of the USB, then I copied the files from the 6.12.3 dl and replaced all EXCEPT the config folder on the drive (there used to be a wiki about whats on the drive and what to actually keep, sadly that wiki article is MIA now :( ).

    That resolved the no-boot brick situation.


    I did upgrade it back to 6.12.4 to see if I could reproduce the VM issue and that did NOT reoccur thankfully (ive not booted the VM's, waiting for current backup to complete, but I can get to the VM section again which is a difference).

    I am leaving this here as a bug report as it did happen and did require me to nuke my USB (sans config folder) in order to recover from a failed rollback.


    Speaking of the secondary issue of reverting it causing it to keel over, if admins want me to see if that's reproduceable let me know and I will make time for it sometime this weekend.

    Edited by Hammerfest
    Link to comment




    Some have fixed that error by removing the virt-manager docker.

    Others seemed to have success by shutting down the docker service first.


    That did not fix it for me, but this did (on 6.11.5):


    virtlog did not show anything extra each time I tried to disable/enable the service, which seems to be an issue on it's own

    Only my syslog showed this:



    Nov  3 11:36:09 xxxxxxxxxx  emhttpd: shcmd (2138): /etc/rc.d/rc.libvirt start
    Nov  3 11:36:09 xxxxxxxxxx  root: virtlockd is already running...

    What worked for me was:


    - Put the service in disable in the GUI and apply

    - Manually kill these processes:

    root@xxxxxxxx:/var/run/libvirt# ps aux | grep libvirt
    root      9216  0.0  0.0  31920  9448 ?        S    11:38   0:00 /usr/sbin/virtlockd -d -f /etc/libvirt/virtlockd.conf -p /var/run/libvirt/virtlockd.pid
    root      9221  0.0  0.0  31920  9564 ?        S    11:38   0:00 /usr/sbin/virtlogd -d -f /etc/libvirt/virtlogd.conf -p /var/run/libvirt/virtlogd.pid

    - In console go to /var/run/libvirt/ (or /run/libvirt)

    - Delete/rename the directory /var/run/libvirt/libvirtsock (not even sure why it's there, was created on boot)

    - Delete/rename the .pid files virtlockd.pid & virtlogd.pid

    - Then put the service in the GUI back to enable and Apply


    This somehow enabled the socket to be used for libvirt, and made it so the system recognized that the other two processes were not running.

    I'm not sure if there a better way to do this, or if all steps were needed, as I am not an experienced user, but I was very glad to do this without removing my libvirt.img file and starting over.

    • Like 1
    Link to comment
    On 11/3/2023 at 9:11 PM, illiewillie said:




    Some have fixed that error by removing the virt-manager docker.

    Others seemed to have success by shutting down the docker service first.


    That did not fix it for me, but this did (on 6.11.5):


    Thank you - this fixed the same issue for me. Appreciate the help!

    Link to comment

    Appreciate the note about virt-manager, I did not have to do that, but whatever it blocked during the update and i copied back over let it work.


    I use the crap outta virt-manager so gonna look for an alternative so i can remove it so it doesnt cause future update issues.


    Might put it in the blacklist for updating unraid.

    Link to comment

    Join the conversation

    You can post now and register later. If you have an account, sign in now to post with your account.
    Note: Your post will require moderator approval before it will be visible.

    Add a comment...

    ×   Pasted as rich text.   Restore formatting

      Only 75 emoji are allowed.

    ×   Your link has been automatically embedded.   Display as a link instead

    ×   Your previous content has been restored.   Clear editor

    ×   You cannot paste images directly. Upload or insert images from URL.

  • Status Definitions


    Open = Under consideration.


    Solved = The issue has been resolved.


    Solved version = The issue has been resolved in the indicated release version.


    Closed = Feedback or opinion better posted on our forum for discussion. Also for reports we cannot reproduce or need more information. In this case just add a comment and we will review it again.


    Retest = Please retest in latest release.

    Priority Definitions


    Minor = Something not working correctly.


    Urgent = Server crash, data loss, or other showstopper.


    Annoyance = Doesn't affect functionality but should be fixed.


    Other = Announcement or other non-issue.

  • Create New...