Jump to content
  • 6.12.6 (and probably .5 as well) break VM with PCI passthrough

    • Closed Minor

    A VM passthrough that had been working up to 6.12.4 inclusive (relevant config files/screenshots attached)W10.xml no longer works with 6.12.6 (I skipped .5, but from the release notes I suspect the issue was introduced there).  Launching the VM now throws an Execution Error:

    internal error: qemu unexpectedly closed the monitor: 2023-12-08T18:46:07.612555Z qemu-system-x86_64: -device {"driver":"vfio-pci","host":"0000:06:00.4","id":"hostdev3","bus":"pci.4","addr":"0x0.0x3"}: vfio 0000:06:00.4: error getting device from group 20: Invalid argument Verify all devices in group 20 are bound to vfio- or pci-stub and not already in use


    IOMMU group 20 only contains 1 device, and it is bound to vfio- (as per the attached screenshot - the page and log output look exactly the same between 6.12.4 and 6.12.6.


    Rolling back to 6.12.4 restores VM functionality.




    User Feedback

    Recommended Comments

    1 hour ago, optiluca said:

    It's attached in the original post, unless you're referring to something different?

    Sorry,   I missed it being beneath the screenshot

    Link to comment

    I have this issue as well.  I upgraded from 6.11.5 to 6.12.6 and my VM stopped working that had an ethernet controller passthrough.  My log file went to 100%. & one of my cpu was running 98% all the time.  I removed my binded ethernet ports from system devices and the cpu went to normal along with the log file to 1%.  Not sure what to do at this point since I need a binded ethernet port to run the VM I have.  Have you come across a fix ? 

    Link to comment

    In my case the PCI passthrough is for the graphics card (I'm passing through the integrated graphics on a Ryzen 5600G).  I have not found a fix, I'm stuck on Unraid 6.12.4.

    Edited by optiluca
    Link to comment

    Did you check that the hardware ID's for the passed through hardware did not change after the upgrade and thus the pass throughs need re-doing?   This is not uncommon after and upgrade.

    Link to comment

    They seem to be unchanged.  Going back to my original issue, the error is:


    Verify all devices in group 20 are bound to vfio- or pci-stub and not already in use


    And IOMMU group 20 only contains 1 device, and it is bound to vfio-...

    Link to comment

    I checked my hardware ID's and all looks well.  What I ended up doing was pulling my RTL8111 ethernet quad card and installed an Intel dual and binded one of the ports to my VM.  Restarted the VM and all is well again.  Looks like the RTL8111 is an issue with 6.12.6 no matter what setup I tried.  I did try the RTL driver APP but the server just has errors and error corrections on boot up with 6.12.6.  All that has since ended since pulling the card out and installing an Intel.  Before all this I did roll back to 6.11.5 and the RTL8111 card worked without issue.  Upgraded again to 6.12.6 and no good no matter how I tried to bind the card to the VM. Hope this helps anyone else that may have the same issue.  

    Link to comment

    I tried 6.12.5, just to be able to confirm when the issue appeared, and can confirm that 6.12.5 also presents this error.  I've downgraded back to 6.12.4 for now.

    Link to comment

    The offending device was a USB controller that I was passing through to the VM.  It's still unclear why this started happening in 6.12.5 - but I've worked around it by not passing through the entire USB controller, but only the individual devices.

    Link to comment

    Join the conversation

    You can post now and register later. If you have an account, sign in now to post with your account.
    Note: Your post will require moderator approval before it will be visible.

    Add a comment...

    ×   Pasted as rich text.   Restore formatting

      Only 75 emoji are allowed.

    ×   Your link has been automatically embedded.   Display as a link instead

    ×   Your previous content has been restored.   Clear editor

    ×   You cannot paste images directly. Upload or insert images from URL.

  • Status Definitions


    Open = Under consideration.


    Solved = The issue has been resolved.


    Solved version = The issue has been resolved in the indicated release version.


    Closed = Feedback or opinion better posted on our forum for discussion. Also for reports we cannot reproduce or need more information. In this case just add a comment and we will review it again.


    Retest = Please retest in latest release.

    Priority Definitions


    Minor = Something not working correctly.


    Urgent = Server crash, data loss, or other showstopper.


    Annoyance = Doesn't affect functionality but should be fixed.


    Other = Announcement or other non-issue.

  • Create New...