Jump to content
  • [6.12.6] Out of memory: Killed process 18556 (avahi-daemon)

    • Closed Minor



    I am seeing a lot of 'Out of memory' reports in my logs. Often prior to a general crash of Unraid (not 100% sure of they are related yet) which require a forced reboot to recover from.

    At the movement my setup is not doing much demanding tasks. I am just trying to transfer the files from my Synology NAS to the Unraid server. However, the frequent crashes have me a bit worried about replacing the Synology (which is a bit dated but rock solid on stability).


    I have noticed a spike in the memory usage after the array is started. Also, possibly after a remote NFS location is mounted however I am still trying to confirm this. 


    I also attached a remote log that contains data that did not survive a crash.


    unraid-diagnostics-20240124-1204.zip remote log - All_2024-1-25-0_58_36.html

    User Feedback

    Recommended Comments

    Unfortunately in these cases, the logs shows the OOM events but not what's causing them, try limiting the RAM for any VMs and/or docker containers, the problem is usually not just about not enough RAM but more about fragmented RAM, failing that disable all services and then then start any VMs and docker containers one by one and let them run enough time to try and confirm if that's the one causing the problem.

    Link to comment

    Thanks for your response. I am only using one docker container at the moment (krusader) to transfer the files. I will try to limit the available resources and see if that has any effect.

    Link to comment

    At the moment the system is running in safe mode. And I put a 8GB cap on the Krusader container. I havent seen any issues yet. After the file transfers are complete, I will restart in the normal mode and see if any of the plugins are causing this.

    • Like 1
    Link to comment

    I think the issue was caused because I mounted (through Unassigned Devices) a network share and used that mount in krusader to tranfer files, which the system did not like.

    I now have mounted the share in krusader directly and see no futher issues. Uptime is now 40+ days. For me the issue is closed.

    Link to comment

    Join the conversation

    You can post now and register later. If you have an account, sign in now to post with your account.
    Note: Your post will require moderator approval before it will be visible.

    Add a comment...

    ×   Pasted as rich text.   Restore formatting

      Only 75 emoji are allowed.

    ×   Your link has been automatically embedded.   Display as a link instead

    ×   Your previous content has been restored.   Clear editor

    ×   You cannot paste images directly. Upload or insert images from URL.

  • Status Definitions


    Open = Under consideration.


    Solved = The issue has been resolved.


    Solved version = The issue has been resolved in the indicated release version.


    Closed = Feedback or opinion better posted on our forum for discussion. Also for reports we cannot reproduce or need more information. In this case just add a comment and we will review it again.


    Retest = Please retest in latest release.

    Priority Definitions


    Minor = Something not working correctly.


    Urgent = Server crash, data loss, or other showstopper.


    Annoyance = Doesn't affect functionality but should be fixed.


    Other = Announcement or other non-issue.

  • Create New...