• [6.9] After moving to 6.9 local GUI mode not working


    NLS
    • Minor

    The whole system seems to be working (VMs, containers, shares)... BUT the local (own) server GUI is not working.
    It actually stays on a clean black screen with a blinking cursor.

    I thought everything was dead until I tried to access web GUI from my main PC and saw everything (else) was ok.
    I rebooted once to see if it was a one time issue, but it wasn't.

    Not sure if the issue classifies as "minor" as it is quite major at least for me (I don't run the server headless).

     

    quasar-ultima-diagnostics-20210306-1918.zip



    User Feedback

    Recommended Comments



    On 3/12/2021 at 1:59 PM, ich777 said:

    Currently the Nvidia Plugin is configured to take over for GUI mode.

    In theory it is possible that I change the plugin again a bit so that you can disable the Nvidia Card for video output...

     

    But I will test a few things after the weekend and will look further into it, can you wait until I have done this?

    I don't want do do only workarounds, I want a proper solution to this and this involves some testing.

     

    May I also ask which onboard graphics do you have? Is it some kind of ASPEED chip?

    I've got as much time as it takes, the system is working fine, it is just that the server is now headless and that is not an issue at all.

    Thank you for what you are doing and for any assistance that you can give me.

     

    I just wanted to update this so that you have all of the info possible. I was able to get access to the display ports on the nvidia card and I am not getting the unraid gui via the display port on the nvidia card either.

     

    Chas

    Edited by kysdaddy
    Added info
    • Like 1
    Link to comment
    Share on other sites

    I have same problem with igpu, I have the Intel top plug installed but have no gui, what's my next option? 

    Link to comment
    Share on other sites

    @coblck

     

     

    On 3/10/2021 at 7:43 AM, ich777 said:

    Have you tried to load the Intel module for your onboard graphics card?

     

    You can also try to:

    1. Press CTRL+ALT+F1 this should bring you back to the command line
    2. Log in with your root user and password
    3. Then type in 'modprobe i915' (without quotes)
    4. Then type in '/etc/rc.d/rc.4' (without quotes)

     

    And please report back.

     

    • Thanks 1
    Link to comment
    Share on other sites

    have you try to uninstall Intel-GPU-TOP Plugin and then run what I send you in my previous message?

    Link to comment
    Share on other sites

    Not yet try tomorrow,  if uninstall plug in the gui will come back surly, if so what do I do to get h/w transcoding back when I remove plug in 

    Link to comment
    Share on other sites
    5 hours ago, coblck said:

    Not yet try tomorrow,  if uninstall plug in the gui will come back surly, if so what do I do to get h/w transcoding back when I remove plug in 

    This is only a workaround for now, will do some more testing next week and report back.

    HW transcoding will work too with this workaround but you have to execute this commands.

    Link to comment
    Share on other sites

    I cant type in commands mate if I don't have a blinking cursor. Do you have to reboot if I manage to type commands in? 

    Link to comment
    Share on other sites

    So uninstalled intel top plugin added command lines and rebooted, now have GUI back and transcoding seems to be working in plex, but always a BUT if i type in cd dev/dri in i get no such such directory ???? this normal 

    Edited by coblck
    Link to comment
    Share on other sites
    10 hours ago, ich777 said:

    This is only a workaround for now, will do some more testing next week and report back.

    HW transcoding will work too with this workaround but you have to execute this commands.

     

    I can confirm that Plex HW transcoding work with the command that get me GUI back.

    • Like 1
    Link to comment
    Share on other sites
    7 hours ago, coblck said:

    I cant type in commands mate if I don't have a blinking cursor. Do you have to reboot if I manage to type commands in? 

    What?

     

    6 hours ago, coblck said:

    So uninstalled intel top plugin added command lines and rebooted, now have GUI back and transcoding seems to be working in plex, but always a BUT if i type in cd dev/dri in i get no such such directory ???? this normal 

    You have to uninstall the Intel-GPU-TOP Plugin, reboot, press CTRL+ALT+F1 when the blinking cursor appears, login with your root user and password, type in modprobe i915 (after that you have the /dev/dri directory) and at last type in /etc/rc.d/rc.4

    If you already uninstalled the Intel-GPU-TOP Plugin then start at press CTRL+ALT+F1 when the blinking cursor appears.

     

     

    Link to comment
    Share on other sites

    I've uninstalled it rebooted and now I have the gui back  and no blinking cursor 

    Edited by coblck
    Link to comment
    Share on other sites
    13 hours ago, coblck said:

    I've uninstalled it rebooted and now I have the gui back  and no blinking cursor 

    But the hardware transcoding is not working I think.

    Link to comment
    Share on other sites
    On 3/11/2021 at 1:10 PM, NLS said:

    modprobe i915 and /etc/rc.d/rc.4 WORKED!

    I have local GUI now.

    May I ask if you had installed the Intel-GPU-TOP Plugin in the first place or did you only installed it to test if it is working after a reboot?

     

    How do you enable the graphics driver on your system did you do a 'touch /boot/config/modprobe.d/i915.conf' or did you enabled it through the go file or don't you enable the i915 module at all?

    Link to comment
    Share on other sites

    Hi @ich777

     

    Just built a small "R&D" machine with iGPU and K4000 this weekend.

     

    Currently only have 3 16Mb Flash devices for storage(boot, array, cache), but enough for what I need at the mo.

     

    let me know if I can assist with any testing.

     

    So far if I just have blank file in modprobe.d for i915, module is loaded and GUI works file.

     

    As soon as I load the intel_gpu_top plugin I loose GUI and get solid cursor. If I boot in non gui mode with plugin installed all is fine.

     

    image.thumb.png.6cba267b59e8fa279aad367388b92688.png

    Link to comment
    Share on other sites

    For all in this thread, the Intel-GPU-TOP Plugin is now fixed and you can reinstall it and local GUI mode will work again just be sure to reboot after you updated the Plugin (make sure that you are on version 2021-03-14a).

     

    FYI: The GUI mode also wasn't working on 6.8.3 nothing on @limetech's end at all...

     

    @NLS please try to install the Intel-GPU-TOP Plugin (remove the file you made for testing purposes 'rm -rf /boot/config/modprobe.d') and see if it works for you now. I think you said that you don't had the Intel-GPU-TOP Plugin installed when you made this request.

     

    @SimonF Thank you for the offer but I think I fixed it now... Please also try to redownload the Plugin or update it and reboot.

    Link to comment
    Share on other sites
    13 minutes ago, ich777 said:

    For all in this thread, the Intel-GPU-TOP Plugin is now fixed and you can reinstall it and local GUI mode will work again just be sure to reboot after you updated the Plugin (make sure that you are on version 2021-03-14).

     

    FYI: The GUI mode also wasn't working on 6.8.3 nothing on @limetech's end at all...

     

    @NLS please try to install the Intel-GPU-TOP Plugin and see if it works for you now. I think you said that you don't had the Intel-GPU-TOP Plugin installed when you made this request.

     

    @SimonF Thank you for the offer but I think I fixed it now... Please also try to redownload the Plugin or update it and reboot.

    GUI Works with it loaded, top is ok, freq errors.

     

    intel-gpu-top -    0/   0 MHz;  100% RC6;  0.00 Watts;        0 irqs/s
    
          IMC reads:       82 MiB/s
         IMC writes:        6 MiB/s
    
              ENGINE      BUSY                                                                                               MI_SEMA MI_WAIT
         Render/3D/0    0.00% |                                                                                            |      0%      0%
           Blitter/0    0.00% |                                                                                            |      0%      0%
             Video/0    0.00% |                                                                                            |      0%      0%
      VideoEnhance/0    0.00% |                                                                                            |      0%      0%
    
    ^C
    root@ComputeNode:~# intel_gpu_frequency 
    intel_gpu_frequency: error while loading shared libraries: libdw.so.1: cannot open shared object file: No such file or directory
    root@ComputeNode:~# 
    
    
    
    
    
    

     

    • Like 1
    Link to comment
    Share on other sites
    9 minutes ago, SimonF said:

    freq errors.

    intel_gpu_freqency is not be needed anymore, this is just a leftover and will be removed in a upcoming version of the plugin. ;)

     

    EDIT: Removed it now... just be sure to be on version 2021.03.14a

    • Like 1
    Link to comment
    Share on other sites

    @ich777 new intel top plugin working a treat thanks very much for all your efforts and patience 

    • Like 1
    Link to comment
    Share on other sites

    @ich177 Just wanted to chime in. I'm in 2021.03.12 of the Nvidia plugin, and even with the Intel GPU Top plugin installed, no bueno. Still get a blank screen with a non-blinking white cursor.

     

    I've tried removing and reinstalling the Nvidia plugin to no avail, since I thought that might be part of the issue. Motherboard is a Supermicro X10DRi, which is Aspeed, I think 2400-based.

     

    For the record, this is the same problem I had with 6.8.3 on the latest IPMI firmware. Since 3.80, they updated the graphics drivers on the board, so I had to downgrade to 3.77 firmware to get GUI mode to work in 6.8.3. Since 6.9's latest drivers, I've been able to run on 3.88 IPMI firmware just fine. Only after this upgrade to 6.9.1, and the first reboot after installing the Nvidia plugin do I seem to have this problem again.

     

    Given that Unraid updated drivers for Aspeed, this shouldn't be a driver issue with the drivers not actually being there, right? This is just some sort of precedence thing? Any ideas on a fix here?

    helium-diagnostics-20210315-1709.zip

    Link to comment
    Share on other sites
    14 hours ago, NLS said:

    @ich777 yeap, you fixed it - plugin fixes the issue

    thanks!

     

    @ich777 I confirm, with gpu intel top plugin, issue fixed (nvidia driver uninstalled).

    Thanks you're a genius.

    • Like 1
    Link to comment
    Share on other sites
    11 hours ago, TechGeek01 said:

    @ich177

    First things first if you quote someone you have to actually click on the name otherwise the person get's no notification @TechGeek01:

    grafik.png.59fa886fec2eca65cf74dead6cde89e7.png

     

    11 hours ago, TechGeek01 said:

    with the Intel GPU Top plugin installed

    The Plugin is only meant if you got a Intel iGPU otherwise it won't work.

     

    May I ask to which card the monitor is connected to?

    If your monitor is connected to the ASPEED onboard graphics you have to do the following:

    if [ ! -d /boot/config/modprobe.d ]; then
    	mkdir -p /boot/config/modprobe.d
    fi
    touch /boot/config/modprobe.d/ast.conf

    EDIT: But from what I see from your Diagnostics you already done that.

    If you connected the monitor to the Nvidia card the Nvidia Plugin should get you covered and bring up the GUI.

    Link to comment
    Share on other sites
    33 minutes ago, Cyril83 said:

    issue fixed (nvidia driver uninstalled).

    Do you need the Nvidia Driver?

    I have no machine where I can test both the Nvidia Driver and the Intel-GPU-TOP Plugin but I think you should be also able to install both and the output should happen on the Nvidia card.

    Link to comment
    Share on other sites
    1 minute ago, ich777 said:

    Do you need the Nvidia Driver?

    I have no machine where I can test both the Nvidia Driver and the Intel-GPU-TOP Plugin but I think you should be also able to install both and the output should happen on the Nvidia card.

    Since you tell me the iGPU can transcode, Nvidia driver is has no utility.

    My graphic card is recognized by Unraid (device) si I will create my VM without nvidia drivers. It should work!

    🙂

     

    • Like 1
    Link to comment
    Share on other sites



    Join the conversation

    You can post now and register later. If you have an account, sign in now to post with your account.
    Note: Your post will require moderator approval before it will be visible.

    Guest
    Add a comment...

    ×   Pasted as rich text.   Restore formatting

      Only 75 emoji are allowed.

    ×   Your link has been automatically embedded.   Display as a link instead

    ×   Your previous content has been restored.   Clear editor

    ×   You cannot paste images directly. Upload or insert images from URL.


  • Status Definitions

     

    Open = Under consideration.

     

    Solved = The issue has been resolved.

     

    Solved version = The issue has been resolved in the indicated release version.

     

    Closed = Feedback or opinion better posted on our forum for discussion. Also for reports we cannot reproduce or need more information. In this case just add a comment and we will review it again.

     

    Retest = Please retest in latest release.


    Priority Definitions

     

    Minor = Something not working correctly.

     

    Urgent = Server crash, data loss, or other showstopper.

     

    Annoyance = Doesn't affect functionality but should be fixed.

     

    Other = Announcement or other non-issue.