Jump to content
  • One of three ZFS datasets not showing up properly after import. (solved - sharenfs feature)

    • Solved Minor

    Following Spaceinvader One's absolutely fantastic video of the upcoming (at the time) release of 6.12 I added my existing ZFS pool into the pools after upgrading.


    After adding it and rebooting - one of the three datasets did not add in properly. I noticed that shares were created to manage the data sets. The one that didn't add properly "rsnapshot" came in empty. I checked the mountpoints both where I had it mounted and where the share put it and they were both empty so I removed the share. (that was a mistake...don't do that! The array can't stop properly because it can't be unmounted).



    zfs list still shows the dataset still exists, but I'm struggling to figure out how to get it imported properly or access it. Not to worry about the data it's just 9TB of backup data from the main array. I have an additional server backing up an additional copy of all the data. I'm not worried about losing it, but I would like to figure out why it isn't being added properly.


    After a forced reboot, the share was added back into the shares and remounted, but the directory is empty. It's doing a parity check since it couldn't unmount the removed share.


    I have attached diagnostics.


    I'm sure there is a wizardly ZFS command that can help with more information, but I'm a newb on that - help me help you with that info. If I recall there was some unusual things about dataset, but I can't remember the specifics.






    Screenshot 2023-06-16 192457.png


    User Feedback

    Recommended Comments

    2 hours ago, JorgeB said:

    Please the post output of:

    zfs mount


    root@CVG02:~# zfs mount
    snapshot/rsnapshot              /mnt/snapshot/rsnapshot
    snapshot                        /mnt/snapshot
    snapshot/NVR                    /mnt/snapshot/NVR
    snapshot/cachemirror            /mnt/snapshot/cachemirror

    This is where I originally had them mounted before upgrade to 6.12.

    They have now also been mounted in /mnt/user/* by 6.12 although that doesn't show up in zfs mount or regular mount.

    Those are the shares created by unraid 6.12. For example, when I go into the folders in /mnt/snapshot/cachemirror or /mnt/user/cachemirror - the same files appear in both.


    It's the rsnapshot one that is blank.

    Link to comment

    I got it!!!


    That share was incompatible because I had sharenfs feature turned on. After turning off that feature AND rebooting, I now have access to the files.


    root@CVG02:/mnt/snapshot/rsnapshot# ls
    alpha.0/  alpha.2/  alpha.4/  beta.0/  beta.2/  beta.4/  beta.6/
    alpha.1/  alpha.3/  alpha.5/  beta.1/  beta.3/  beta.5/


    So officially the "BUG" is unraid 6.12 is not compatible with sharenfs zfs feature.

    Which probably isn't something that needs to be fixed, just use the NFS share in the share created by unraid.


    Thanks again for integrated ZFS support and continuing to make what I consider to be the most flexible of all the home server operating systems that caters to all tech levels.

    Edited by wildfire305
    • Like 1
    Link to comment

    Join the conversation

    You can post now and register later. If you have an account, sign in now to post with your account.
    Note: Your post will require moderator approval before it will be visible.

    Add a comment...

    ×   Pasted as rich text.   Restore formatting

      Only 75 emoji are allowed.

    ×   Your link has been automatically embedded.   Display as a link instead

    ×   Your previous content has been restored.   Clear editor

    ×   You cannot paste images directly. Upload or insert images from URL.

  • Status Definitions


    Open = Under consideration.


    Solved = The issue has been resolved.


    Solved version = The issue has been resolved in the indicated release version.


    Closed = Feedback or opinion better posted on our forum for discussion. Also for reports we cannot reproduce or need more information. In this case just add a comment and we will review it again.


    Retest = Please retest in latest release.

    Priority Definitions


    Minor = Something not working correctly.


    Urgent = Server crash, data loss, or other showstopper.


    Annoyance = Doesn't affect functionality but should be fixed.


    Other = Announcement or other non-issue.

  • Create New...