Jump to content
  • Unable to set my appdata share as exclusive in 6.12.1


    sittingmongoose
    • Closed

    I was previously running my dockers, and docker image on /mnt/cache/ instead of /mnt/user/ but this new exclusive share feature seems to be a better solution. However, I turned on permit exclusive shares in the global share settings. I cant select to turn on exclusive shares in the share tab though for my appdata. Currently its primary storage is my cache pool, secondary storage is set to none.

    Screenshot 2023-06-28 085139.png




    User Feedback

    Recommended Comments

    This suggests the share exists somewhere else, can be just a folder, go to Shares click on appdata and then compute and post a screenshot of that.

    Link to comment

    Didn't notice in the screenshot before that NFS is enabled, any shares with NFS enabled cannot be exclusive.

    Link to comment
    2 minutes ago, JorgeB said:

    Didn't notice in the screenshot before that NFS is enabled, any shares with NFS enabled cannot be exclusive.

    Sorry I realized that after posting, they are disabled now but it didnt help.  I also rebooted.

     

    Screenshot 2023-06-28 091503.png

    Link to comment
    33 minutes ago, JorgeB said:

    Didn't notice in the screenshot before that NFS is enabled, any shares with NFS enabled cannot be exclusive.

    Some combination of making sure no files were on the array, turning off nfs sharing, and rebooting multiple times fixed it.

    Link to comment

    If you're coming from google. I had to re-enable NFS globally, go to each share i wanted exclusive and set NFS export to No, save, change secondary storage from None to Array, save, change secondary storage back to None, save. Re-disable NFS globally. That did it.

     

    This system isn't realizing that NFS is disabled globally.

    Link to comment

    I don't know if this is already tracked somewhere else, but imo this bug isn't solved! I know it is difficult to handle, since the NFS service can be started dynamically, the symlinks not, but to just ignore the global setting can't be part of the solution. Sorry, if I sound a little blunt, english isn't my first language and I am still a little bit upset since this bug cost me last 4 hours.

     

    My proposed solution:

    • A tooltip on the field itself which rules for an exclusive share has been broken
    • Disable the NFS Export button if NFS has been enabled after the symlink has been created (this is a bug either way, you can do that currently)

     

    With this you could use the global NFS setting again.

    Link to comment


    Join the conversation

    You can post now and register later. If you have an account, sign in now to post with your account.
    Note: Your post will require moderator approval before it will be visible.

    Guest
    Add a comment...

    ×   Pasted as rich text.   Restore formatting

      Only 75 emoji are allowed.

    ×   Your link has been automatically embedded.   Display as a link instead

    ×   Your previous content has been restored.   Clear editor

    ×   You cannot paste images directly. Upload or insert images from URL.


  • Status Definitions

     

    Open = Under consideration.

     

    Solved = The issue has been resolved.

     

    Solved version = The issue has been resolved in the indicated release version.

     

    Closed = Feedback or opinion better posted on our forum for discussion. Also for reports we cannot reproduce or need more information. In this case just add a comment and we will review it again.

     

    Retest = Please retest in latest release.


    Priority Definitions

     

    Minor = Something not working correctly.

     

    Urgent = Server crash, data loss, or other showstopper.

     

    Annoyance = Doesn't affect functionality but should be fixed.

     

    Other = Announcement or other non-issue.

×
×
  • Create New...