Jump to content
  • Unraid 6.12.2 Firtzbox Issues

    • Annoyance

    I have posted before here (regarding 6.12 and 6.12.1) but apparently this also appies with 6.12.2. You can find the original Thread here: (in german though)



    I have had Unraid running for weeks/months without any problem on 6.11.X - That was why i updated without hesitation when 6.12 came along.

    As soon as I updated to 6.12 my server kept crashing. For no apparent reason. That's why i updated to 6.12.1 as soon as it came along (it came along very quickly)

    I tried several things (keep reading to find out what) the server was running somewhat stable but my reverse proxy didn't work anymore, so you can take the last sentece and replace 6.12.1 with 6.12.2,  That's why i updated to 6.12.2 as soon as it came along (and again: it came along very quickly)

    Now honestly I just want to go back to 6.11.x because it seems everything is messed up and I think it is somewhat of a network problem.

    I have a Fritzbox with a DHCP and a certain setup. is my Fritzbox ( Modell: FRITZ!Box 7590 FRITZ!OS:7.56-Version aktuell)

    The Fritzbox has a DHCP with the following setup:

    Home Network Settings:
    Valid 10 Days
    Local DNS-Server:
    (it used to be my adguard docker container but since the server kept crashing I had to bypass it for other devices to stay online)

  is my Unraid Server It has a couple of dockers (mostly bridge, 2 custom br0, and a couple of VMs)


    My Important Docker Containers (among others - all which are not mentioned run in bridge mode):

    • Adguard-Home IP Network mode: br0
    • ApacheGuacamole IP Network mode: bridge (used to be another ip in 6.11.X and br0)
    • mariadb IP Network mode: bridge
    • Nextcloud IP Network mode: bridge (used to be another ip in 6.11.X and br0)
    • openVPN-as IP Network mode: bridge (I need it because I have somthing which only works with openVPN and not Wireshark unfortunately)
    • swag IP  Network mode: bridge (used to be another ip in 6.11.X and br0)
    • tvheadend IP Network mode: br0 (not important as much but it is my only other br0 container so I wanted to include it in the list)
    • vaultwarden IP Network mode: bridge (used to be another ip in 6.11.X and br0)


    As said those are my most important ones. 

    I do have a couple of VMS nothing fancy

    mainly 2 Windows VMS in the 10.10.10 Network

    Home Assistant (why you may ask -  i like a clean cut so that i have all smart home devices in 10.10.11.X range)#


    Now here comes the weirdest part:


    Ever since the 6.12 Update the fritzbox is acting up:

    Usually I had a port forwarding to the swag container (back when it had the br0 setting to its IP) 

    Also one port forwarding to openVPN-as

    All my devices/docker containers were corretly named automatically by the fritzbox. That is ever since 6.12 completely gone:

    If i switch to macvlan: My Server is suddenly listed twice (2 different mac adresses though)

    with arp -a I figured out that one "Server" is infact Ad-guard

    tvheadend isn't showing up at all - not in the fritzbox nor with arp-a however i can access the webinterface locally

    When I try to add a portforwarding to my server/swag with the right ports the fritzbox gives me 

    "Es ist ein Fehler aufgetreten.
    Fehlerbeschreibung: Fehler beim Speichern (Daten inkonsistent)."
    An Error occured.
    Description: Error while saving (data inconsistent).


    So back to ipvlan:

    Everything seems to work just fine (and i almost deleted this thread i had written)... until something happenend... I don't know what causes this exactly but in my fritzbox, messes up the Ips of my server and it's docker containers... This is especially weird since i have set the ip of the server to static and also have checked the box to always assign the same ip on the fritzbox.

    In the Overview of the fritzbox it shows up correctly:


    When I click on edit it shows a differen IP

    as for example seen here:


    This would be the tvheadend container... Sometimes (i don't know how this works) it shows up as the adguard container

    The problem is that the port forwarding is then switched to this ip.... 

    I would love to give a few containers a dedicated ip adress if possible.


    The thing is: I have a mainboard with 3(!) Network ports... of which 2 are not connected as I had trouble getting everything to work in the past. Here are my specs:


    and of course a diagnostics zip is included here as well as syslog.

    For now i have deactivated adguard and tvheadend. (yay... ads and no tv... :D)

    I really love if someone could help me (and possibly many many other german, austrian and swiss users as fritzbox is the nonplusultra consumer device here) 

    server-syslog-20230701-0714.zip server-diagnostics-20230701-0911.zip

    User Feedback

    Recommended Comments

    I have fritzbox and had issues with Unraid 6.11 with static IP addresses. The Fritzbox was very confused when identifying the Unraid server, even though the MAC matched and unraid had a static IP, the Fritxbox was trying to allocate another IP address...


    I ended up fixing it by resetting the Fritxbox and re-entering all my configuration! Not a fun task, but it seems to have resolved the issue I was seeing. Might not be related to your issue, but information in case it helps!


    (btw, Fritzbox is also the default router for Zen customers in the UK, so more countries to add to the list 😀 )

    Link to comment

    Well the thing is, in the german thread there are users adding up who are having the same problem.

    Until now I don't really have a solution. 

    I have basically removed all br0 docker containers and the system runs BUT(!) (and that's a very big but) i have a home assistant vm which my reverse proxy can't reach no matter what I do. I need that vm to be accessable from the outside world....

    I am changing the status to urgent, since more and more users seem to have the exact same problem.

    Link to comment

    IPvlan operates in a mode which shares the same MAC address amongst multiple IP addresses.

    It seems to me that the Fritzbox can not handle that, it apparently wants to act on unique MAC addresses when doing port forwarding. Can the Fritzbox act on IP address instead?


    A couple of workarounds:


    1. If you don't use VMs then the 'bridge' function is not needed on eth0 and you can use MACvlan directly on the interface, which doesn't cause call traces in my testing.


    2. Use docker containers on a dedicated interface (eth1) with no IP addresses assigned and again no bridging enabled for this interface. This separates docker communication completely from system communication.


    Link to comment

    Join the conversation

    You can post now and register later. If you have an account, sign in now to post with your account.
    Note: Your post will require moderator approval before it will be visible.

    Add a comment...

    ×   Pasted as rich text.   Restore formatting

      Only 75 emoji are allowed.

    ×   Your link has been automatically embedded.   Display as a link instead

    ×   Your previous content has been restored.   Clear editor

    ×   You cannot paste images directly. Upload or insert images from URL.

  • Status Definitions


    Open = Under consideration.


    Solved = The issue has been resolved.


    Solved version = The issue has been resolved in the indicated release version.


    Closed = Feedback or opinion better posted on our forum for discussion. Also for reports we cannot reproduce or need more information. In this case just add a comment and we will review it again.


    Retest = Please retest in latest release.

    Priority Definitions


    Minor = Something not working correctly.


    Urgent = Server crash, data loss, or other showstopper.


    Annoyance = Doesn't affect functionality but should be fixed.


    Other = Announcement or other non-issue.

  • Create New...