• Posts

  • Joined

  • Last visited

Everything posted by angyen

  1. I just tried installing tailscale in debian VM with the --accept-routes command. while in the vm I can access to other LAN subnet, but when my router forward the route to by debian vm, the connection still not pass through and I can't connect to other LAN subnet. Tracert reveal that the connection broke at the debian VM. Looks like there is a setting that needed to be done. I got to study it futher. If anyone know what to change to make it work. Please let me know. Thank you.
  2. Yes. the setting for unraid and docker both for net.ipv4_forward = 1 but still it doesn't work. Thank you for the suggestion. Truly appreciate that.
  3. Thank you for the swift reply. I have setup wireguard in these 2 unraid server but now my ISP is migrating all public IP to private IP, which is why I need to deploy Tailscale as my wireguard will cease to function once I no longer have a public IP. Looks like I got to figure out another alternative way to install Tailscale, maybe through a VM under unraid.
  4. I am trying to make all devices on 3 different LANs on 3 different locations to be able to connect to each other via Tailscale. 2 location tailscale via this docker in unraid and another tailscale run over raspberry pi. Successfully advertise routes for 3 different LAN Subnets, and if I am running Tailscale on my PC I am able to connect to all devices from 3 different LAN Now what I would like to achieve is that for all devices under the 3 different LANs can connect to each other without running tailscale on the PC. I have setup static route at my router to point to the LAN address of Unraid, I executed the command "tailscale up --accept-routes --advertise-routes=LOCAL LAN/24". However, when I run tracert in windows, the connection stop at my local UNRAID IP and not being forwarded via Tailscale. May I know what setting do I missed up at my local UNRAID server or tailscale docker to make the connection possible?
  5. "when a peer is behind NAT or a firewall, it might wish to be able to receive incoming packets even when it is not sending any packets. Because NAT and stateful firewalls keep track of "connections", if a peer behind NAT or a firewall wishes to receive incoming packets, he must keep the NAT/firewall mapping valid, by periodically sending keepalive packets. This is called persistent keepalives. When this option is enabled, a keepalive packet is sent to the server endpoint once every interval seconds. A sensible interval that works with a wide variety of firewalls is 25 seconds. Setting it to 0 turns the feature off, which is the default, since most users will not need this, and it makes WireGuard slightly more chatty. This feature may be specified by adding the PersistentKeepalive = field to a peer in the configuration file, or setting persistent-keepalive at the command line. If you don't need this feature, don't enable it. But if you're behind NAT or a firewall and you want to receive incoming connections long after network traffic has gone silent, this option will keep the "connection" open in the eyes of NAT." Source: This is exactly my situation, my peer is not having a public IP due to ISP restriction. How do I configure persistant-keepalive in my Unraid Wireguard Peer setting?