Figro

Members
  • Posts

    25
  • Joined

  • Last visited

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

Figro's Achievements

Newbie

Newbie (1/14)

10

Reputation

  1. So I did address this before but it seems like somewhere that got reverted. I added the --no-autoupdate flag back to the script. Updating the container should show this line on startup. 2023-06-16T16:12:42Z INF Settings: map[no-autoupdate:true token:*****] Hopefully this will stop that issue. I will monitor this behavior on the next release of cloudflared
  2. Use the container that @Slippin' Jimmy mentioned. I am looking into this
  3. Hey Guys, This seems to be happening when a new release of cloudflared is released (one just came out last night). I believe I addressed this once but I am also being affected by this. I will look over the documentation and will see what I can update to stop this behaviour. Ill reply here when I get around to doing so. In the meantime you will need to manually restart which is annoying and not the long term solution. Thanks
  4. I just updated the container to hopefully address this issue. I could not replicate the issue myself but I have already pushed an update that does change the line that gave you an error. you should be able to check for updates and update and try that out. If you still are having the same issue. I would guess there is some type of network filtering when it is trying to download the binary. There shouldn't be anything you are doing that is incorrect. As long as your token is valid and nothing in the network is preventing the binary from being downloaded it should run fine. Not sure how comfortable you are with command line but if you are comfortable you could try manually downloading the binary with this command: url=$(curl -s https://api.github.com/repos/cloudflare/cloudflared/releases/latest | jq -r '.assets[] | select(.browser_download_url | endswith("cloudflared-linux-amd64")) | .browser_download_url') && curl -L --output "cloudflared" $url && chmod +x ./cloudflared && ./cloudflared -h If everything is good result should show the help command output from cloudflared. I Hope this solves your issue. Would like to know if this issue has affected anyone else as well
  5. I use the :dev tag as the latest release has issues connecting with qbittorrent. I do not use Deluge but maybe try a second instance with the dev tag and see if there is any difference. I have not seen that Error when launching the application before. Sorry I can't be of more help
  6. Restarting the container should download the latest release of cloudflared.
  7. Hello, Can you try to remove the appdata directory completley and try again. Make sure you are on not using the :dev tag for the repository line. String should be "figro/leon-ai". Try spinning up the container after doing that and see if the same error occurs. If it does try giving your user rwx permission to the appdata folder for leon. I didn't need to explicitly give my user permission to get it to work. But I did just test on a fresh install and was able to get it up and running. I have attached the logs from my run for reference. Would be interested to know if anyone else is still running into issues. If you discover something new feel free to update logs.txt
  8. I just updated the container with an update that addressed the issues you guys were facing with leon-AI. sorry for the delay in response. I have been busy with other things. Please try removing the current appdata for leon and starting the container with the latest docker build and let me know if you run into any issues
  9. I don't have much experience with hosting game servers through cloudflared tunnels as I usually just use a ddns service such as duckdns for my own servers that I share with a couple of friends. I do know that there are limitations in terms of upload limits on the free tier which im guessing you are on (as am I). I tried putting nextcloud behind my cloudflared tunnel and it would rate limit me or tell me The entity I was uploading was too large (HTTP 413). Thats what I would guess would be causing the packet loss issues in your game server. I would just avoid using cf tunnels for certain things such as this. Here are some things you can try to diagnose the cause if you are interested. You can add a port to the unraid template and use the console for the container to launch the metrics server on that port to get further information from the tunnel. I will plan to add this as an addition env port that can be setup for this type of thing. I have some related screenshots below for this. Open cosole for the container and run: ./cloudflared tunnel --metrics 0.0.0.0:4321 run --token $token these metrics can also be put into grafana to make a more friendly looking UI with graphs that is easier to read. more information on the cloudflare docs here: https://developers.cloudflare.com/cloudflare-one/connections/connect-apps/do-more-with-tunnels/grafana/
  10. Is there more to those logs? from what I can see those are just warnings and there should be more stuff under the block you posted. Let me know I will be happy to help
  11. Hello, I have changed the application to use the release on the :latest branch if you would like to go back to how it used to be please change the docker repo to be figro/flood-ui:dev as stated in my last post there seems to be an issue in the latest release of flood that is not compatible with the latest version of qbittorent. They have the issue fixed in the development branch and you can build it and use that just fine but it does not seem that they have released a built binary with that fix yet. I had a couple of errors building it however making some small changes to the source code fixed that. If you run into that let me know and I can tell you what to change to fix that. Thanks
  12. So I have addressed that update for flood-ui. Updating the container should download the release and launch that instead. You can also free up some storage space by wiping appdata files before updating as all those files are no longer needed. If you want to stay on the dev version there is a :dev tag that has not changed. Keep in mind there seems to be bug for qbittorent in the latest release and doesnt allow you to connect if you are using the latest qbittorent version. The dev branch seems to fix this for me however I have to fix some files to fix some building errors on that. Hopefully they release the fix for that soon in the next release so that is not required. If anyone needs helping getting this to work with qbitorrent let me know and I will try and help. I will address the update for leon-ai tomorrow with the same approach. Please let me know if there are other issues since this update and I will do my best to address those. Thanks!
  13. Sorry for such a late reply. Been busy with work and other projects. While I haven't touched the Leon-AI container in a while but I do use the flood-ui container daily however the way they are deployed in the container are similar and from the provided logs looks like its being caused by changes in the github project which the container will clone. I did this so that development on those projects were possible however it looks like this leads to alot more dynamic issues as each person may have a different pulled version of those projects. I will most likely release an update that does not pull the source from github and instead will just execute a prebuilt binary. This will prob mean that development is not possible anymore although i may address this issue with different tags you can pull from dockerhub. Sorry for the issues you have been facing. Until that update is addressed if you are able to get the container working I would recommend not deleting it's appdata so that it will not repull from github. Thanks,
  14. This here is the only thing I added under the tunnel in cloudflare's zero trust dashboard. Then under zero trust settings (not under the tunnel) in settings > network, under firewall you will see split tunnels in the manage page make sure the CIDR of your network that you added to the tunnel before is not in this list if you have "Exclude IPs and domains" selected. If you have Include selected make sure it is in the list. After this I just connected to the warp client (make sure you are authenticated with your zero trust login) and you should be able to access local IPs from outside your network via Warp. Hope this helps
  15. Just tried this. Took a couple mins to propagate but it is working for me as well. Very cool. Thanks for sharing this