papkee

Members
  • Posts

    2
  • Joined

  • Last visited

papkee's Achievements

Newbie

Newbie (1/14)

0

Reputation

  1. Turns out it was either a permissions issue, a vpn config issue, or a combination of the two. I re-downloaded my mullvad config files, and made sure everything in the config directory had the correct permissions for the UID/PID of the container to access it. Starts up fine now.
  2. I'm getting a strange issue after pulling the latest image. I made an issue on github as well but this forum seems to be more active. Essentially, I get two fatal errors on startup and then the container hangs after starting OpenVPN. Doesn't even seem to try and start rtorrent and gets stuck in a loop of timing out on the ping watchdog. Here's where the two fatal errors pop up: 2020-05-17 11:34:10,420 DEBG 'start-script' stdout output: [info] Attempting to load tun kernel module... 2020-05-17 11:34:10,421 DEBG 'start-script' stderr output: modprobe: FATAL: Module tun not found in directory /lib/modules/4.15.0-96-generic 2020-05-17 11:34:10,421 DEBG 'start-script' stdout output: [warn] Unable to load tun kernel module using modprobe, trying insmod... 2020-05-17 11:34:10,422 DEBG 'start-script' stderr output: insmod: ERROR: could not load module /lib/modules/tun.ko: No such file or directory 2020-05-17 11:34:10,423 DEBG 'start-script' stdout output: [warn] Unable to load tun kernel module, assuming its dynamically loaded 2020-05-17 11:34:10,429 DEBG 'start-script' stdout output: [info] Attempting to load iptable_mangle module... 2020-05-17 11:34:10,430 DEBG 'start-script' stderr output: modprobe: FATAL: Module iptable_mangle not found in directory /lib/modules/4.15.0-96-generic 2020-05-17 11:34:10,431 DEBG 'start-script' stdout output: [warn] Unable to load iptable_mangle module using modprobe, trying insmod... 2020-05-17 11:34:10,431 DEBG 'start-script' stderr output: insmod: ERROR: could not load module /lib/modules/iptable_mangle.ko: No such file or directory 2020-05-17 11:34:10,432 DEBG 'start-script' stdout output: [warn] Unable to load iptable_mangle module, you will not be able to connect to the applications Web UI or Privoxy outside of your LAN I've attached the full (sanitized) startup log to the post as well. This is using the same exact startup command that I've been using for months with zero issues. I didn't change any config, just pulled the latest image and re-created the container. docker run -d \ --restart unless-stopped \ --cap-add=NET_ADMIN \ -p 7080:9080 \ -p 7443:9443 \ -p 8118:8118 \ --name=tdrs-rt \ -v /media/RomeoBravo/tdrs-rt:/data \ -v /home/papkee/docker-seedbox/rtorrent/config:/config \ -v /home/papkee/docker-seedbox/rtorrent/themes:/usr/share/webapps/rutorrent/plugins/theme/themes \ -v /etc/localtime:/etc/localtime:ro \ -e VPN_ENABLED=yes \ -e VPN_PROV=custom \ -e STRICT_PORT_FORWARD=yes \ -e ENABLE_PRIVOXY=no \ -e ENABLE_AUTODL_IRSSI=no \ -e ENABLE_RPC2=yes \ -e ENABLE_RPC2_AUTH=yes \ -e ENABLE_WEBUI_AUTH=yes \ -e RPC2_USER=<> \ -e RPC2_PASS=<> \ -e WEBUI_USER=<> \ -e WEBUI_PASS=<> \ -e LAN_NETWORK=192.168.0.0/24 \ -e NAME_SERVERS=209.222.18.222,37.235.1.174,1.1.1.1,8.8.8.8,209.222.18.218,37.235.1.177,1.0.0.1,8.8.4.4 \ -e DEBUG=false\ -e PHP_TZ=America/Chicago \ -e UMASK=002 \ -e PUID=1003 \ -e PGID=1003 \ binhex/arch-rtorrentvpn Help would be appreciated. I tried deleting all local images of the container and re-pulling everything, but I get the same result either way. binhex startup failure.txt