Jump to content

binhex

Community Developer
  • Content Count

    4256
  • Joined

  • Last visited

  • Days Won

    9

binhex last won the day on July 31

binhex had the most liked content!

Community Reputation

348 Very Good

About binhex

  • Rank
    All that you can do is watch them play

Converted

  • Gender
    Undisclosed
  • URL
    https://goo.gl/psyfQx
  • Personal Text
    Addicted to the internet

Recent Profile Visitors

5748 profile views
  1. click on the 'check for updates' button in the unraid web ui, if update is available then click on 'update all' or or the 'force update' link (shown only in advanced view)
  2. ive now included a socks5 server in docker image privoxyvpn, so you can now point hexchat at the socks5 proxy and it will connect and use that (tested and working!).
  3. hmm so custom bridge seems to have a limitation/bug, if you choose custom bridge then it looks like you cannot define both host and container port, so yor only option is default bridge (or host of course).
  4. your screenshot looks a bit wacky!, it should look like this:- note you will need to switch to bridge or custom bridge first, then apply, then edit again and then add the ports, defining both container AND host port.
  5. you havent defined the container port, you need to set the host and container port for each port i listed above
  6. you will need to define all of these ports:- -p 32400:32400 \ -p 32400:32400/udp \ -p 32469:32469 \ -p 32469:32469/udp \ -p 5353:5353/udp \ -p 1900:1900/udp note - this is not recommended!, some plex clients may not be able to communicate with the plex server (thus host mode is the default).
  7. ok bit of quick testing, here is what is going on:- firstly this container is supposed to run in host mode, this means no defined ports (not required as it talks directly on the hosts network). You then switched the network type from 'host' to 'bridge' or 'custom bridge', the problem now is you wont be able to connect to the container because there are no defined ports, and because there are no ports defined the web ui link wont show (as there are no ports to map the link to). so two ways around this:- 1. dont change it from host mode and be happy, you will see the web ui link. 2. switch to bridge or custom bridge and define the required ports for plex, you wll then magically see the web ui link will show (tested this). so why isnt this a problem with the other images you listed? because they are designed to run in bridge mode, with defined ports, so no issue.
  8. the correct network type for this particular docker image (and also plex) is 'host', if you are running it in any other mode then unless you are ok with defining the multiple ports and possible issues with connecting to certain plex clients then you COULD run it in bridge mode. if switching mode from host to bridge or custom bridge is preventing the webui option from displaying then this is purely a unraid web ui bug, and should be raised as such, there isnt anything i can do to work around this, link to issues:- https://forums.unraid.net/bug-reports/stable-releases/
  9. np :-), i will enhance the FAQ i linked to for cases where the wrong umask has previously been set as well as apparmor trip up.
  10. ok in that case i can only assume it has created files with umask 777, and thus no permissions on the existing file, you will need to delete the /config/nginx/security/auth on the host side and then restart, this SHOULD then regenerate the file with the correct permissions (now that umask is correct). alternatively delete everything in /config and restart so it re-creates the whole lot with correct permissions.
  11. not in that log you just attached there isnt, i see no sign of the nginx permission denied message
  12. i got a faq for that, q2:- https://github.com/binhex/documentation/blob/master/docker/faq/rtorrentvpn.md
  13. this is your issue:- 2019-08-15 08:42:09.985802 [info] UMASK defined as '777' a umask of 777 = no permissions for anybody for any newly created files or folders, set it to 000 or 002 if you want to restrict.