iLaurens

Members
  • Posts

    7
  • Joined

  • Last visited

Posts posted by iLaurens

  1. On 10/29/2020 at 11:33 AM, mgutt said:

    I do not own an AMD iGPU, but I found this thread and so I wrote the following script to execute it on an Unraid server to build and install a Mesa 20.10 slackware package:

    
    ...

    As I already created the package this way, feel free to use this alternatively:

    
    ...

     

    Now I think you only need to pass the /dev/dri path to the Plex container as described here:

    https://forums.unraid.net/topic/77943-guide-plex-hardware-acceleration-using-intel-quick-sync/

     

    Maybe its needed to set an environment variable as described here:

    https://emby.media/community/index.php?/topic/72084-going-mental-over-ryzen-2400g-vega-vaapi/page/2/&tab=comments#comment-880533

     

    Good luck!

     

    I find it marvelous that you would go this length to build these drivers without even owning an AMD! I own a ryzen 2400g and tried to install your package. It would install (or so it says), but there is no existence of any /dev/dri when I look for it. Shouldn't it simply show up when I enter the command ls /dev? I did try a reboot to no avail. Should I go ahead and pass /dev/dri to the plex server container anyway?

  2. On 10/11/2020 at 11:36 PM, iLaurens said:

    @binhex great work for fixing it. It all works like a charm again with PIA port forwarding. Been a big fan of this for a long time already. There is just one thing that used to work that does not work anymore; connecting to a specific IP of PIA's VPN severs. Before next-gen, I could replace the domain name (example: de-frankfurt.privacy.network) and replace it with an IP to ensure I'd get the same public IP assigned after a restart of the container. The connection to PIA still works when I select a specific IP, but the port forwarding somehow fails. It says that the port serving page of PIA refuses the connection (http://209.222.18.222:2000/?client_id=xxxx). I have no idea why the port forwarding suddenly breaks when trying to fix the IP in the openvpn configuration file, but is this something you could still have a look at? Some torrent sites are really paranoid and require me to provide a static IP :( The domain names rotate between a set of IPs for each region so you'll almost always have a different public IP after restarting the container or if the connection resets.

    I figured out what the likely culprit is. I see from your github that the nextgen PIA servers also require a new method of obtaining a port. Hence the two functions: `get_incoming_port_nextgen` and `get_incoming_port_legacy`. The nextgen function is only chosen if the VPN_REMOTE_SERVER env variable contains `privacy.network`. However when I explicitly set an IP in my openvpn config (from the nextgen servers) it will still select the old `get_incoming_port_legacy`. Could you possibly add an optional docker environment var that forces the get_incoming_port_nextgen to be selected? Maybe make it such that:

     

    if [[ "${VPN_REMOTE_SERVER}" == *"privacy.network"* || "${FORCE_PIA_NEXTGEN:-false}" == "true"]]; then

    Notice how I set a default value for FORCE_PIA_NEXTGEN (but you can also set default in Dockerfile). So you can leave it out of your dockerman definition and people need not know it even exists. However people that know about this environment variable setting (perhaps if you put it in the FAQ) could use this to force nextgen functionality. This would help people like me that want a static VPN IP from PIA.

  3. @binhex great work for fixing it. It all works like a charm again with PIA port forwarding. Been a big fan of this for a long time already. There is just one thing that used to work that does not work anymore; connecting to a specific IP of PIA's VPN severs. Before next-gen, I could replace the domain name (example: de-frankfurt.privacy.network) and replace it with an IP to ensure I'd get the same public IP assigned after a restart of the container. The connection to PIA still works when I select a specific IP, but the port forwarding somehow fails. It says that the port serving page of PIA refuses the connection (http://209.222.18.222:2000/?client_id=xxxx). I have no idea why the port forwarding suddenly breaks when trying to fix the IP in the openvpn configuration file, but is this something you could still have a look at? Some torrent sites are really paranoid and require me to provide a static IP :( The domain names rotate between a set of IPs for each region so you'll almost always have a different public IP after restarting the container or if the connection resets.

  4. On 9/26/2020 at 9:57 PM, binhex said:

    it will be 2.x, if you are running 1.x then you are on a old tagged version, check your tag in the repository and/or do a 'force update' to get the latest image.

    Will you also update PIA VPN connection with older versions of deluge? I prefer to stick with Deluge 1.3 because of the Windows Thin Client and some plugins not working in 2.0.