DockX

Members
  • Posts

    13
  • Joined

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

DockX's Achievements

Newbie

Newbie (1/14)

1

Reputation

  1. No, I don't have two accounts. Just having the same problem like everyone else and hoped to get some help...
  2. Hi, thanks for testing it @saarg. I guess it has something to do with SWAG then. Here is my compose file: version: "3.3" services: swag: container_name: SWAG image: linuxserver/swag cap_add: - NET_ADMIN ports: - 80:80 - 443:443 volumes: - /data/SWAG:/config - /data/Nextcloud_config/log/nextcloud:/config/log/nextcloud restart: unless-stopped environment: - PUID=1000 - PGID=100 - EMAIL=* - URL=* - SUBDOMAINS=* - ONLY_SUBDOMAINS=true - DHLEVEL=4096 - TZ=Europe/Berlin nextcloud: image: linuxserver/nextcloud container_name: nextcloud hostname: Nextcloud environment: - PUID=1000 - PGID=100 - TZ=Europe/Berlin ports: - 8011:443 volumes: - /data/Nextcloud_config:/config - /data/Nextcloud_data:/data depends_on: - mariadb - redis restart: unless-stopped mariadb: image: linuxserver/mariadb container_name: mariadb environment: - PUID=1000 - PGID=100 - MYSQL_ROOT_PASSWORD=* - TZ=Europe/Berlin volumes: - /data/MariaDB:/config Maybe subfolder.conf needs a change: ## Version 2020/12/09 # Assuming this container is called "swag", edit your nextcloud container's config # located at /config/www/nextcloud/config/config.php and add the following lines before the ");": # 'trusted_proxies' => ['swag'], # 'overwritewebroot' => '/nextcloud', # 'overwrite.cli.url' => 'https://your-domain.com/nextcloud', # # Also don't forget to add your domain name to the trusted domains array. It should look somewhat like this: # array ( # 0 => '192.168.0.1:444', # This line may look different on your setup, don't modify it. # 1 => 'your-domain.com', # ), # Redirects for DAV clients location = /.well-known/carddav { return 301 $scheme://$host/nextcloud/remote.php/dav; } location = /.well-known/caldav { return 301 $scheme://$host/nextcloud/remote.php/dav; } location /nextcloud { return 301 $scheme://$host/nextcloud/; } location ^~ /nextcloud/ { include /config/nginx/proxy.conf; resolver 127.0.0.11 valid=30s; set $upstream_app nextcloud; set $upstream_port 443; set $upstream_proto https; proxy_pass $upstream_proto://$upstream_app:$upstream_port; rewrite /nextcloud(.*) $1 break; proxy_max_temp_file_size 2048m; proxy_set_header Range $http_range; proxy_set_header If-Range $http_if_range; proxy_redirect off; proxy_ssl_session_reuse off; }
  3. I have tried incognito and other devices. But the message stays.
  4. upstream php-handler { server 127.0.0.1:9000; } server { listen 80; listen [::]:80; server_name _; return 301 https://$host$request_uri; } server { listen 443 ssl http2; listen [::]:443 ssl http2; server_name _; ssl_certificate /config/keys/cert.crt; ssl_certificate_key /config/keys/cert.key; # Add headers to serve security related headers # Before enabling Strict-Transport-Security headers please read into this # topic first. add_header Strict-Transport-Security "max-age=15768000; includeSubDomains;" always; # # WARNING: Only add the preload option once you read about # the consequences in https://hstspreload.org/. This option # will add the domain to a hardcoded list that is shipped # in all major browsers and getting removed from this list # could take several months. # set max upload size client_max_body_size 512M; fastcgi_buffers 64 4K; # Enable gzip but do not remove ETag headers gzip on; gzip_vary on; gzip_comp_level 4; gzip_min_length 256; gzip_proxied expired no-cache no-store private no_last_modified no_etag auth; gzip_types application/atom+xml application/javascript application/json application/ld+json application/manifest+json application/rss+xml application/vnd.geo+json application/vnd.ms-fontobject application/x-font-ttf application/x-web-app-manifest+json application/xhtml+xml application/xml font/opentype image/bmp image/svg+xml image/x-icon text/cache-manifest text/css text/plain text/vcard text/vnd.rim.location.xloc text/vtt text/x-component text/x-cross-domain-policy; # HTTP response headers borrowed from Nextcloud `.htaccess` add_header Referrer-Policy "no-referrer" always; add_header X-Content-Type-Options "nosniff" always; add_header X-Download-Options "noopen" always; add_header X-Frame-Options "SAMEORIGIN" always; add_header X-Permitted-Cross-Domain-Policies "none" always; #add_header X-Robots-Tag "none" always; add_header X-XSS-Protection "1; mode=block" always; # Remove X-Powered-By, which is an information leak fastcgi_hide_header X-Powered-By; root /config/www/nextcloud/; # display real ip in nginx logs when connected through reverse proxy via docker network set_real_ip_from 172.0.0.0/8; real_ip_header X-Forwarded-For; # Specify how to handle directories -- specifying `/index.php$request_uri` # here as the fallback means that Nginx always exhibits the desired behaviour # when a client requests a path that corresponds to a directory that exists # on the server. In particular, if that directory contains an index.php file, # that file is correctly served; if it doesn't, then the request is passed to # the front-end controller. This consistent behaviour means that we don't need # to specify custom rules for certain paths (e.g. images and other assets, # `/updater`, `/ocm-provider`, `/ocs-provider`), and thus # `try_files $uri $uri/ /index.php$request_uri` # always provides the desired behaviour. index index.php index.html /index.php$request_uri; # Rule borrowed from `.htaccess` to handle Microsoft DAV clients location = / { if ( $http_user_agent ~ ^DavClnt ) { return 302 /remote.php/webdav/$is_args$args; } } location = /robots.txt { allow all; log_not_found off; access_log off; } # Make a regex exception for `/.well-known` so that clients can still # access it despite the existence of the regex rule # `location ~ /(\.|autotest|...)` which would otherwise handle requests # for `/.well-known`. location ^~ /.well-known { # The following 6 rules are borrowed from `.htaccess` location = /.well-known/carddav { return 301 /remote.php/dav/; } location = /.well-known/caldav { return 301 /remote.php/dav/; } # Anything else is dynamically handled by Nextcloud location ^~ /.well-known { return 301 /index.php$uri; } try_files $uri $uri/ =404; } # Rules borrowed from `.htaccess` to hide certain paths from clients location ~ ^/(?:build|tests|config|lib|3rdparty|templates|data)(?:$|/) { return 404; } location ~ ^/(?:\.|autotest|occ|issue|indie|db_|console) { return 404; } # Ensure this block, which passes PHP files to the PHP process, is above the blocks # which handle static assets (as seen below). If this block is not declared first, # then Nginx will encounter an infinite rewriting loop when it prepends `/index.php` # to the URI, resulting in a HTTP 500 error response. location ~ \.php(?:$|/) { fastcgi_split_path_info ^(.+?\.php)(/.*)$; set $path_info $fastcgi_path_info; try_files $fastcgi_script_name =404; include /etc/nginx/fastcgi_params; fastcgi_param SCRIPT_FILENAME $document_root$fastcgi_script_name; fastcgi_param PATH_INFO $path_info; fastcgi_param HTTPS on; fastcgi_param modHeadersAvailable true; # Avoid sending the security headers twice fastcgi_param front_controller_active true; # Enable pretty urls fastcgi_pass php-handler; fastcgi_intercept_errors on; fastcgi_request_buffering off; } location ~ \.(?:css|js|svg|gif)$ { try_files $uri /index.php$request_uri; expires 6M; # Cache-Control policy borrowed from `.htaccess` access_log off; # Optional: Don't log access to assets } location ~ \.woff2?$ { try_files $uri /index.php$request_uri; expires 7d; # Cache-Control policy borrowed from `.htaccess` access_log off; # Optional: Don't log access to assets } location / { try_files $uri $uri/ /index.php$request_uri; } } And yes, Iam on latest.
  5. What can I do if deleting the file does not help? Its not a caching issue, tried with several devices. Iam also using the SWAG reverse Proxy, so maybe it has something to do with the proxy conf? Maybe someting has to be added in this file too? https://raw.githubusercontent.com/linuxserver/reverse-proxy-confs/master/nextcloud.subfolder.conf.sample
  6. Thanks alot, so dumping the Database is just for compressing the database and save space?
  7. Beside the HTTP header bug that noone else has (but thanks alot for the effort saarg 🙂 ), I have another question. Whats the best way to backup Nextcloud? I have read about tar and sql dump but shouldn't it be enough to just copy the config volumes somewhere else? Or is the dump and the tar process only to save disk space but both options would work?
  8. Since you both also use nextcloud, how did you configure the X - Robots - Tag ? Do you have an entry for it in SWAG?
  9. The issue is, that you always get the "the “ X - Robots - Tag ” HTTP header is not configured to equal to “none” warning, when you configure your swag with "none, noindex, nofollow, nosnippet, noarchive". When you have more than just "none" the warning appears, and only "none" is not enough for all crawlers.
  10. I have created everything new today, SWAG, Nextcloud, MariaDB and the warning remains. Should be easy to reproduce. I have the add_header line above the line where ssl.conf is included like its suggested in the readme. To not have it twice I disabled the add_header line inside the nextcloud container, message is there anyway though, disabled or not. Any other Ideas?
  11. Hi, Iam using Nextcloud from Linuxserver.io behind SWAG. I always have the Message "the “ X - Robots - Tag ” HTTP header is not configured to equal to “none” when more than none is configured e.g. add_header X-Robots-Tag “none, nosnippet, noarchive”. When only "none" is configured everything is fine. Any Ideas why, is it a bug?
  12. Hi, I want to use the onlyoffice documentserver for nextcloud behind the proxy but as subfolder. aptalca posted a solution here which is working fine, but not for subfolder. onlyoffice described a proxy-to-virtual-path here but I could not get it to work. Iam not so experienced with nginx. Any Ideas how a subfolder solution have to look like? Thanks in advance.