joselito

Members
  • Posts

    5
  • Joined

  • Last visited

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

joselito's Achievements

Newbie

Newbie (1/14)

0

Reputation

  1. sorry, but which? I use it from your site on github
  2. It is something else, not the memory error. reinstalled a least 10x in the night: ``` sudo docker run -d --name="Zoneminder" --net="bridge" --privileged="false" --shm-size="30G" -p 888:80/tcp -p 9001:9001/tcp -p 6802:6802/tcp -e TZ="Europe/Berlin" -e PUID="1000" -e PGID="1000" -e INSTALL_HOOK="1" -e INSTALL_FACE="1" -e INSTALL_TINY_YOLOV3="1" -e INSTALL_YOLOV3="1" -e INSTALL_TINY_YOLOV4="1" -e INSTALL_YOLOV4="1" -e MULTI_PORT_START="0" -e MULTI_PORT_END="0" --device /dev/dri:/dev/dri -v "/mnt/Zoneminder":"/config":rw -v "/mnt/Zoneminder/data":"/var/cache/zoneminder":rw -v "/media/zm":"/mnt/zm":rw dlandon/zoneminder ``` or: ``` version: '3.1' services: zoneminder: container_name: Zoneminder image: dlandon/zoneminder:latest restart: unless-stopped ports: - 888:80/tcp - 9001:9001/tcp - 6802:6802/tcp network_mode: "bridge" privileged: false shm_size: 32G environment: - TZ=Europe/Berlin - PUID=1000 - PGID=1000 - INSTALL_HOOK=1 - INSTALL_FACE=0 - INSTALL_TINY_YOLOV3=0 - INSTALL_YOLOV3=0 - INSTALL_TINY_YOLOV4=0 - INSTALL_YOLOV4=1 - MULTI_PORT_START=0 - MULTI_PORT_END=0 volumes: - /mnt/Zoneminder:/config:rw - /mnt/Zoneminder/data:/var/cache/zoneminder:rw - /media/zm:/mnt/zm:rw devices: - /dev/dri:/dev/dri ``` I get always if I install INSTALL_HOOK=1: ``` Unrecoverable error:'ml_sequence' Traceback:Traceback (most recent call last): File "/var/lib/zmeventnotification/bin/zm_detect.py", line 531, in <module> main_handler() File "/var/lib/zmeventnotification/bin/zm_detect.py", line 295, in main_handler if g.config['ml_sequence'] and g.config['use_sequence'] == 'yes':KeyError: 'ml_sequence' ``` If i install with INSTALL_HOOK=0, then the error dissapered but no zm_detect in logs
  3. How to update ES?? added new config for ES in objectconfig.ini: [ml] use_sequence = yes disable_locks= no stream_sequence = { 'frame_strategy': 'most_models', 'frame_set': 'snapshot,alarm', 'contig_frames_before_error': 5, 'max_attempts': 3, 'sleep_between_attempts': 4, 'resize':800 } ml_sequence= { 'general': { 'model_sequence': 'object' }, 'object': { 'general':{ 'pattern':'(car|truck|bicycle|motorbike|bus|person|dog|cat)', 'same_model_sequence_strategy': 'first' # also 'most', 'most_unique's }, 'sequence': [{ # YoloV4 on GPU if TPU fails (because sequence strategy is 'first') 'object_config':'{{base_data_path}}/models/yolov4/yolov4.cfg', 'object_weights':'{{base_data_path}}/models/yolov4/yolov4.weights', 'object_labels': '{{base_data_path}}/models/yolov4/coco.names', 'object_min_confidence': 0.3, 'object_framework':'opencv', 'object_processor': 'gpu' }] } Also tried to disable use_sequence: no, but dont work.