locutus_lbc

Members
  • Posts

    7
  • Joined

  • Last visited

locutus_lbc's Achievements

Newbie

Newbie (1/14)

2

Reputation

  1. Really good to see you back on board, but take your time. Nothing is more important than your health. That sounds great. If you have time, please have a look 1-2 pages back as some of us discussed several issues with and wishes for the Auto Fan Plugin: - Feature Request: add NVME devices to exclude list via GUI, cause they influence the measurements of the spinning drives (works if manually added to cfg file, but will be overwritten if changes in the GUI are made) - Feature Request: have the option to give every fan an individual name in Auto Fan - and System Temp Plugin - possible Bug: if first cfg file in the plugin folder has service="0" the auto fan services does not start on boot/array start or crashes/stopps (workaround: delete all cfg files with service="0" in it) If you need more details on this feel free to contact me. Until than... Stay save, stay healthy kind regards from berlin
  2. And I can confirm that it actually works to exclude NVME devices, when you add them directly to the config file. BUT be careful with the UI... the setting will not be shown if you add a NVME device in the config AND the config file will be overwritten, if you change something in the GUI (so the NVME drive is gone). before changing the file via terminal please be sure that the service has stopped. to kill all services run: /usr/local/emhttp/plugins/dynamix.system.autofan/scripts/autofan -q maybe you have to run it more than once. for me it just stopped only one instance of the service. I have 2 fan controllers configured. Check with 'htop' if everything stopped, otherwise kill them in 'htop'. after that change your config file with: nano /flash/config/plugins/dynamix.system.autofan/dynamix.system.autofan*.cfg replace the * with your corresponding config file. In the config file I changed two lines... Here is an example of one of my controllers config with a NVME devices excluded. options="-c /sys/devices/platform/nct6775.656/hwmon/hwmon3/pwm4 -f /sys/devices/platform/nct6775.656/hwmon/hwmon3/fan2_input -l 30 -t 30 -T 40 -m 1 -e sdp,nvme0n1" service="1" controller="/sys/devices/platform/nct6775.656/hwmon/hwmon3/pwm4" fan="/sys/devices/platform/nct6775.656/hwmon/hwmon3/fan2_input" pwm="30" low="30" high="40" interval="1" exclude="sdp,nvme0n1" Please notice that I changed it once in the 'exclude' parameter (last line) and once in the 'options' parameter which constructs the service I guess. Restart your service with: /usr/local/emhttp/plugins/dynamix.system.autofan/scripts/rc.autofan restart or /usr/local/emhttp/plugins/dynamix.system.autofan/scripts/rc.autofan start I saw here in the forums that some people had also problems excluding there NVME devices. Hope that the developer will take care of it, but it seems that there is a workaround until then. Kind regards from Berlin
  3. thx for your help in this case. i can confirm what @TexasUnraid said. same behavior on my side. i just deleted the files where service=0 and will see if this helps. i just noticed over night that the service again stopped but I was pretty sure that I ran the command before going to bed. In the morning the service said "stopped", after restarting manually again I saw just some minutes ago that the service stopped again from itself. don't know if this relates to @TexasUnraid's assumption that the first file has to have a service=1 in that folder. So I tried your suggestion with deleting all files with service=0... let's see if the service is stable now. do you have an idea how to check via console if the service is running or not and than maybe fire up the 'start' command as cron every 5min? This would also help i guess but bash scripting and me are no good friends edit: I also put in the name of my nvme drive in the exclude list (in my case it is 'nvme0n1')... let's see if this prevents the fans from getting info from the wrong drive.
  4. or you might want to add a script like this to your custom script plugin and run it after array has started: #!/bin/bash /usr/local/emhttp/plugins/dynamix.system.autofan/scripts/rc.autofan 'start' you can test it before in your console kind regards
  5. I made something custom for my use case out of this template: https://gist.github.com/kidpixo/04d61b42221f6bc8489b
  6. Agreed as well!! +1 for the Auto Start Option with Server or Array Start... I'm using a custom script to check and/or restart like it was suggested here in the forums. Would be great to get rid of this
  7. My No.1 feature request for the Auto Fan Plugin is to have the option to name the detected fans individually. In the System Temp Plugin it would be appreciated as well and on the Dashboard Widget. After some days I always forget, which one was for what. Startin' to get old Would be great if you consider this as a useful new feature. kind regards from Berlin