Cytomax

Members
  • Posts

    21
  • Joined

  • Last visited

Converted

  • Gender
    Undisclosed

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

Cytomax's Achievements

Newbie

Newbie (1/14)

1

Reputation

  1. Sorry i thought this was for all the linuxserver.io containers... im just running it in a manjaro box using docker... So i figured it out... 1.16.0-ls67 and 1.16.0-ls68 dont work for me 1.16.0-ls66 does work for me... Something changed between 1.16.0-ls66 and 1.16.0-ls67 that causes the container to crash Hopefully its just me and its not some bigger problem...
  2. I want to start by saying letsencrypt/swag is amazing and i have been running it successfully for the last couple years.... i usually update every few weeks or so... i ran an update today like normal... no recent config changes... and the container keeps crashing... i backed up the container and made a new folder to start from scratch and the container keeps crashing.... Here are the logs... no idea what to do now.... ------------------------------------- swag | _ () swag | | | ___ _ __ swag | | | / __| | | / \ swag | | | \__ \ | | | () | swag | |_| |___/ |_| \__/ swag | swag | swag | Brought to you by linuxserver.io swag | ------------------------------------- swag | swag | To support the app dev(s) visit: swag | Certbot: https://supporters.eff.org/donate/support-work-on-certbot swag | swag | To support LSIO projects visit: swag | https://www.linuxserver.io/donate/ swag | ------------------------------------- swag | GID/UID swag | ------------------------------------- swag | swag | User uid: 1000 swag | User gid: 1000 swag | ------------------------------------- swag | swag | [cont-init.d] 10-adduser: exited 0. swag | [cont-init.d] 20-config: executing... swag | [cont-init.d] 20-config: exited 0. swag | [cont-init.d] 30-keygen: executing... swag | using keys found in /config/keys swag | [cont-init.d] 30-keygen: exited 0. swag | [cont-init.d] 50-config: executing... swag | Variables set: swag | PUID=1000 swag | PGID=1000 swag | TZ=America/New_York swag | URL=*MY MAIN DOMAIN* swag | SUBDOMAINS=*QUICK EDIT* swag | EXTRA_DOMAINS= swag | ONLY_SUBDOMAINS=false swag | VALIDATION=dns swag | CERTPROVIDER= swag | DNSPLUGIN=cloudflare swag | EMAIL=*QUICK EDIT MY EMAIL IS HERE* swag | STAGING=false swag | swag | Using Let's Encrypt as the cert provider swag | SUBDOMAINS entered, processing swag | SUBDOMAINS entered, processing swag | Sub-domains processed are: *QUICK EDIT THERE ARE LOTS OF SUBDOMAINS* swag | E-mail address entered: *QUICK EDIT MY EMAIL IS THERE* swag | dns validation via cloudflare plugin is selected swag | Certificate exists; parameters unchanged; starting nginx swag | Starting 2019/12/30, GeoIP2 databases require personal license key to download. Please retrieve a free license key from MaxMind, swag | and add a new env variable "MAXMINDDB_LICENSE_KEY", set to your license key. swag | [cont-init.d] 50-config: exited 0. swag | [cont-init.d] 60-renew: executing... swag | The cert does not expire within the next day. Letting the cron script handle the renewal attempts overnight (2:08am). swag | [cont-init.d] 60-renew: exited 0. swag | [cont-init.d] 70-templates: executing... swag | [cont-init.d] 70-templates: exited 0. swag | [cont-init.d] 90-custom-folders: executing... swag | chown: changing ownership of '/config/custom-cont-init.d': Operation not permitted swag | chown: changing ownership of '/config/custom-services.d': Operation not permitted swag | [cont-init.d] 90-custom-folders: exited 1. swag | [cont-finish.d] executing container finish scripts... swag | [cont-finish.d] done. swag | [s6-finish] waiting for services. swag | [s6-finish] sending all processes the TERM signal. swag | [s6-finish] sending all processes the KILL signal and exiting. swag exited with code 1
  3. I went to the discord server and found an answer i thought i would post it here in case it helps anyone else out all i had to do was change set $upstream_app homeassistant; to set $upstream_app home-assistant;
  4. I wanted to start off by saying thank you for your hardwork and making using a reverse proxy easy to use, I am successfully using swag for a lot of different services in my home so i know swag is working great with https I can successfully access my Home-Assistant container from anywhere inside and outside my network with http://homeassistant.home.specialdomain.com:8123 Questions I am trying to get home assistant to work with swag reverse proxy https exactly the same way as my 10 other apps that i have but it is failing with 502 Bad Gateway After searching the Home Assistant forums there seem to be some extra steps that need to be added to the config file but i am not 100% sure what to do Here are the 2 leading guides that explain how to use Lets Encrypt with HA from scratch https://community.home-assistant.io/t/reverse-proxy-using-nginx/196954 https://community.home-assistant.io/t/nginx-reverse-proxy-set-up-guide-docker/54802 Hopefully there is something that is missing in the default SWAG container homeassistant.subdomain.conf file that needs to be added to get this to work Here is my setup Docker-Compose File home-assistant: image: homeassistant/home-assistant:stable container_name: home-assistant environment: - TZ=America/New_York volumes: - /etc/localtime:/etc/localtime:ro - /media/username/nfsset/containers/home-assistant/config:/config ports: - 8123:8123 #network_mode: host restart: unless-stopped Completely Default homeassistant.subdomain.conf # make sure that your dns has a cname set for homeassistant and that your homeassistant container is not using a base url server { listen 443 ssl; listen [::]:443 ssl; server_name homeassistant.*; include /config/nginx/ssl.conf; client_max_body_size 0; # enable for ldap auth, fill in ldap details in ldap.conf #include /config/nginx/ldap.conf; # enable for Authelia #include /config/nginx/authelia-server.conf; location / { # enable the next two lines for http auth #auth_basic "Restricted"; #auth_basic_user_file /config/nginx/.htpasswd; # enable the next two lines for ldap auth #auth_request /auth; #error_page 401 =200 /ldaplogin; # enable for Authelia #include /config/nginx/authelia-location.conf; include /config/nginx/proxy.conf; resolver 127.0.0.11 valid=30s; set $upstream_app homeassistant; set $upstream_port 8123; set $upstream_proto http; proxy_pass $upstream_proto://$upstream_app:$upstream_port; } } Sorry for the lengthy post but i tried to be as complete as possible
  5. this happened to me... looks like the place i was using doesnt work anymore so i picked a different location... the gui doesnt load if your vpn cant make a connection is what i am assuming
  6. Same thing happened to me... i just deleted the whole container and started over again... unless someone has a better idea
  7. ROFL.. well i feel dumb... looks like qbitorrent wasnt starting because the bahamas.ovpn file wasnt working.. i changed to a different .ovpn file and everything loaded up.... oh well i learned a lot about modules
  8. looks like bahamas isnt working, i changed to a different ovpn and it works now... bahamas must be bugged
  9. Yup i downloaded the zip file at https://www.privateinternetaccess.com/openvpn/openvpn-nextgen.zip pulled out a .pem .crt and .ovpn and placed them in the /config/openvpn/ directory, i did this like maybe a month ago and everything was working great then maybe a couple weeks ago it just stopped working.. the only thing i can think of is i updated the qbittorrent container via docker compose pull and it stopped working after that
  10. The same thing happened to me but i am running qbitorrentVPN bin hex .... i am using PIA VPN.... i never updated the server which is running kubuntu 18.04.5 i wonder if it was the latest build that has some issues
  11. I have been using this container along with SWAG from linuxserver.io on my trusty Ubuntu 18.04.5 standalone server for at least a year if not longer. I dont remember the last time i touched the server much less updated it...its been working great, out of no where the webgui stopped working i get this error 502 Bad Gateway nginx/1.18.0 My logs mentioned modprob: FATAL: Module iptable_mangle not found in directory /lib/modules/5.4.0-54-generic so then i used sudo /sbin/modprobe iptable_mangle and that got resolved but now its complaining about not loading the tun mod modprobe: FATAL: Module tun not found in directory /lib/modules/5.4.0-54-generic How do i fix this? Things i have tried to fix the problem upgraded to 20.04 sudo chown -R 777 /entire container directory made sure the UID and GID in the docker compose file match the user issuing the docker-compose command EDIT I just found this https://www.kernel.org/doc/Documentation/networking/tuntap.txt I'm gonna read it and see what I find Thanks in Advance
  12. welp that settles it... i only changed from qbittorrent because i was too dumb to realize i needed the nextget vpn files and not the old files so i tried deluge and got like 8 megaBytes per second went back to qbittorrent and downloaded 4 Ubuntu ISO's and got to 32 megaBytes without breaking a sweat its absolutely possible different times of the day may of caused this bottle neck but w/e i like the interface of qbittorrent better anways Thanks binhex for great work!
  13. which ovpn file did you pick (what location)? is it one of the approved locations that it mentions in the log when starting deluge
  14. pretty sure its megaBytes per second... which isnt terrible if im downloading 1 torrent with that but if i download multiple Linux ISO i cant pass a total of 8ish which is pretty bad.. im going to try qbittorrent and see if there is any difference
  15. i used to use qbittorrent all the time but i stopped torrenting for like a month and then when i came back it didnt work when i tried after the nextgen switch so i went to deluge, i realized i was using the old openvpnconfig and i am going to retry qbittorrent with the new nextgen opnenvpn config https://www.privateinternetaccess.com/openvpn/openvpn-nextgen.zip the biggest thing i miss about qbittorrent is total traffic summary as well as total download and total upload.. i cant find a way to enable it on deluge