Jump to content

Gobs

Members
  • Content Count

    18
  • Joined

  • Last visited

Community Reputation

0 Neutral

About Gobs

  • Rank
    Member

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. Except I can't set it up since if I go to http://SERVER_IP:32400/web/index.html# and sign in Plex cannot find any servers. EDIT: I think this is an issue with Plex. The account that originally claimed the server was deleted, but it would appear that it's still in the Plex database somehow since I cannot create an account with the same email address. I assume then that Plex still considers the server to be claimed by that account, and so won't let any other account claim it.
  2. Yes, as in if I go to http://SERVER_IP:32400/web/index.html# I am greeted with a sign in page. I sign in and then Plex looks for servers but to no avail.
  3. It is. Nginx log is shown below as well. In the Nginx log I saw this: [cont-init.d] 50-config: exited 0. [cont-init.d] done. [services.d] starting services [services.d] done. Server ready Signal handled: Terminated. [cont-finish.d] executing container finish scripts... [cont-finish.d] done. [s6-finish] syncing disks. [s6-finish] sending all processes the TERM signal. [s6-finish] sending all processes the KILL signal and exiting. But again, nextcloud works while plex doesn't which is weird.
  4. The plex.subdomain.conf: # make sure that your dns has a cname set for plex, if plex is running in bridge mode, the below config should work as is, for host mode, # replace the line "proxy_pass https://$upstream_plex:32400;" with "proxy_pass https://HOSTIP:32400;" HOSTIP being the IP address of plex # in plex server settings, under network, fill in "Custom server access URLs" with your domain (ie. "https://plex.yourdomain.url:443") server { listen 443 ssl; server_name plex.*; include /config/nginx/ssl.conf; client_max_body_size 0; proxy_redirect off; proxy_buffering off; # enable for ldap auth, fill in ldap details in ldap.conf #include /config/nginx/ldap.conf; location / { # enable the next two lines for http auth #auth_basic "Restricted"; #auth_basic_user_file /config/nginx/.htpasswd; # enable the next two lines for ldap auth #auth_request /auth; #error_page 401 =200 /login; include /config/nginx/proxy.conf; resolver 127.0.0.11 valid=30s; set $upstream_plex plex; proxy_pass https://$upstream_plex:32400; proxy_set_header Upgrade $http_upgrade; proxy_set_header Connection "upgrade"; proxy_set_header X-Plex-Client-Identifier $http_x_plex_client_identifier; proxy_set_header X-Plex-Device $http_x_plex_device; proxy_set_header X-Plex-Device-Name $http_x_plex_device_name; proxy_set_header X-Plex-Platform $http_x_plex_platform; proxy_set_header X-Plex-Platform-Version $http_x_plex_platform_version; proxy_set_header X-Plex-Product $http_x_plex_product; proxy_set_header X-Plex-Token $http_x_plex_token; proxy_set_header X-Plex-Version $http_x_plex_version; proxy_set_header X-Plex-Nocache $http_x_plex_nocache; proxy_set_header X-Plex-Provides $http_x_plex_provides; proxy_set_header X-Plex-Device-Vendor $http_x_plex_device_vendor; proxy_set_header X-Plex-Model $http_x_plex_model; } } Nginx is listening to port 180 and 1443, since ports 80 and 443 are forwarded on my router to 180 and 1443. Both nginx and plex are running on a custom network in bridge mode.
  5. I posted here before about getting plex to work with a reverse proxy, I now have another problem. After rebooting my server, Nextcloud still works beautifully as before, however when I try to go to https://plex.mysubdomain.url I get a 502 bad gateway error. What logs could I look at to find out what's the problem? Any help on the matter?
  6. @happyagnostic So I only just found out what was wrong - having done what you suggested (port forwarding parameters + using Plex with the custom network) I was able to reach my plex, but it still said server unreachable. This was because I use uMatrix to prevent websites from loading scripts, and it was preventing access to plex.tv, so I disabled this and everything works fine now, I'm so happy! I'm still a bit confused as to how the port forwarding works. If I understand correctly, I request goes to plex.mydomain.com through port 443, which is then forwarded to port 1443 by my router, letsencrypt / nginx recieves this request then forwards it to port 32400 on the plex docker? Does that sound about right?
  7. @happyagnostic So I tried that (adding port forward 32400, protocol = TCP) and adding the lines that you wrote. The good news: I can actually open the Plex GUI now, but I just get a page saying: Plex is not reachable. Make sure your server has an internet connection and any firewalls or other programs are set to allow access. So back to square one. (This is when I run it in custom bridge mode - if I run it in host mode, I can at least access my files but still get complaints about not being able to reach Plex and I can't sign in).
  8. That did the trick. The array didn't appear because I didn't have autostart enabled. Thank you for the help!
  9. Thank you! What about it not seeing the array?
  10. I had to move my unRAID machine recently, and upon reboot I got the following errors Web GUI doesnt show up. I go to the IP address (which is always 192.168.0.18, configured my router to do that), I try mediaserver.local, even tower.local and nothing. The array isnt showing. Specifically, I hooked up a mouse and keyboard (and a graphics card) to my server and when I cd to /mnt/ all I see is disks, and there's no directories in there. I can only assume that unRAID therefore does not see array. I think these are probably two seperate problems, with the former being due to nginx perhaps (the only thing different since my last reboot was my setting up Nextcloud to be used outside my house). I've attached my diagnostics file. Will also try to start the server in safe mode. tower-diagnostics-20181104-2032.zip
  11. Should that read UnRaidIP:1443:32400? Also you said you cannot access plex from outside your local network this way? Because if that's the case I might as well just run plex in host mode and have done with it.
  12. Yes Yes My router's settings page says no ports are restricted (should I be worried?) but Is My Port Open says it's not. Port 443 (HTTPS) seems to be the only open port, but I think that's how it should be? I don't quite understand how reverse proxy and lets encrypt works, but as I understand that requests from the outside world go myip:443 -> myserver:32400. Also Nextcloud works, so I would be surprised if that's the problem. Yes it is. Any other suggestions?
  13. For future reference, on Ubuntu 18.04 when going to Other Locations you get presented with the options below. Sometimes I've noticed there's no distinction between Remote Login (sftp) and File Sharing (smb), but you want to use sftp which is significantly faster. I also installed Dynamix Cache Directories and span up the hard drives, but that didn't have as much of an effect. Thank you for the help! mediaserver-diagnostics-20181001-1738.zip
  14. mediaserver-diagnostics-20181001-1738.zip How would I go about doing that? Is this on unRAID or on my laptop(s)? Do I need a cache for my unRAID system? (I built the server with my brother and he said that the CPU we used doesn't support cache if I remember correctly). mediaserver-diagnostics-20181001-1738.zip
  15. I followed spaceinvaderone's guide to setting up reverse proxies and letsencrypt and wanted to get this to work for me with plex. I do the following: Create a CNAME for my domain called 'plex', so should be able to access plex through 'plex.mydomain.com' (not my real domain obviously) Put my duckdns domain + token into the DuckDNS container settings Setup port forwarding as described in the spaceinvaderone video (80 -> 180, 443 -> 1443) Setup a user defined network 'proxynet' Run letsencrypt using 'proxynet' Install linuxserver.io's plex container and make it use the 'proxynet' network Check that the plex.subdomain.conf file is set up correctly, shown below I then try to run plex by clicking on the WebGUI option in the docker tab and my browser fails to open plex - I get 'Problem loading page' and the address bar at the top of the browser writes http://172.18.0.4:32400/web. I cannot access the Plex GUI by typing 192.168.0.18:32400, https://plex.mydomain.com doesn't work either. In essence it does not seem to work in any other way than host mode, and even in host mode Plex gets stuck on this page: Any help would be appreciated. # make sure that your dns has a cname set for plex, if plex is running in bridge mode, the below config should w$g the IP$address of plex # replace the line "proxy_pass https://$upstream_plex:32400;" with "proxy_pass https://HOSTIP:32400;" HOSTIP bei$.yourdom$in.url:443") # in plex server settings, under network, fill in "Custom server access URLs" with your domain (ie. "https://ple$ server { listen 443 ssl; server_name plex.*; include /config/nginx/ssl.conf; client_max_body_size 0; proxy_redirect off; proxy_buffering off; # enable for ldap auth, fill in ldap details in ldap.conf #include /config/nginx/ldap.conf; location / { # enable the next two lines for http auth #auth_basic "Restricted"; #auth_basic_user_file /config/nginx/.htpasswd; # enable the next two lines for ldap auth #auth_request /auth; #error_page 401 =200 /login; include /config/nginx/proxy.conf; resolver 127.0.0.11 valid=30s; set $upstream_plex plex; proxy_pass https://$upstream_plex:32400; proxy_set_header Upgrade $http_upgrade; proxy_set_header Connection "upgrade"; proxy_set_header X-Plex-Client-Identifier $http_x_plex_client_identifier; proxy_set_header X-Plex-Device $http_x_plex_device; proxy_set_header X-Plex-Device-Name $http_x_plex_device_name; proxy_set_header X-Plex-Platform $http_x_plex_platform; proxy_set_header X-Plex-Platform-Version $http_x_plex_platform_version; proxy_set_header X-Plex-Product $http_x_plex_product; proxy_set_header X-Plex-Token $http_x_plex_token; proxy_set_header X-Plex-Version $http_x_plex_version; proxy_set_header X-Plex-Nocache $http_x_plex_nocache; proxy_set_header X-Plex-Provides $http_x_plex_provides; proxy_set_header X-Plex-Device-Vendor $http_x_plex_device_vendor; proxy_set_header X-Plex-Model $http_x_plex_model; } }