SuberSeb

Members
  • Posts

    48
  • Joined

About SuberSeb

  • Birthday April 27

Converted

  • Gender
    Male

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

SuberSeb's Achievements

Rookie

Rookie (2/14)

2

Reputation

  1. Yadif is a deinterlacing filter. I think this is just bug in unmanic. It stucks only at the time when it tries to transfer file from cache to the destination directory. So I think that unmanic transfer entire file to RAM for no reason. Ffmpeg can't waste so much of RAM, so it's an issue in unmanic itself.
  2. Are you using custom ffmpeg options or yadif?
  3. This is just limit RAM usage by service but this will not fix problem with converting. If I limit RAM usage then I got this error: kernel: Memory cgroup out of memory: Killed process 2733 (unmanic-service) total-vm:15112168kB, anon-rss:4151332kB, file-rss:7820kB, shmem-rss:3832kB, UID:99 pgtables:8324kB oom_score_adj:0 After this unmanic can't transfer converted file from cache to library directory. Seems that unmanic tries to load full video file in RAM which is awful (tmp folder NOT IN RAM).
  4. I have some really bad OOM errors while using Unmanic. Cache dir set to share, not to RAM. While I'm converting .ts H264 video file to H265 using nvenc, it goes above 100% to 200% and after this entire server get stuck. Almost about 32 gigabytes of RAM is used by Unmanic, so I can't convert this file at all. It happens not on every content. What should I do? I have tried all versions of Unmanic, also I'm using custom ffmpeg options - yadif enabled and vbr.
  5. Same bug here. It's been a long time since first bug report. When the fix will be ready?
  6. So maybe it's not a bug, but this is really annoying. I think this shouldn't work like this. You need to turn off hard links or cache on share to prevent this errors. It's not solution for this problem because you have to broke one functionality to fix another.
  7. Because of stale file handles I switched to NFS. SMB have this issue too. The only way is to disable cache on that shares or disable hard links. I described it here:
  8. I think this is a problem for specific users if they don't have enough knowledge But custom options will be very useful. Now I need to change lib.php to mount my shares with needed params.
  9. Is there a way to run custom nfs mount command? Noac option is very slow in my case, I'd like to remove it. I think it's a quiet simple to add an option to specify custom params for NFS. In lib.php.
  10. Yes, RAID1 btrfs cache on all shares (10GbE network). If I turn off cache, there are no more stale file handle errors. But this is not an option for me.
  11. Thank you all for support. I turned off hard links and there are no more stale file handle errors. But this solution works only for NFS. My SMB shares still have that problem. Also turning off hard links affects important functionality (sonarr, radarr, lidarr, etc.). I think that turning off hard links is not a good solution for that problem because you fix one functionality and broke another. That errors is really annoying, servers just can't make backups to each other.
  12. Yeah. I have set this to -1. Also I tried to disable hard links when I'm using SMB, it doesn't help.
  13. Set this to -1. I will check if it works. If it doesn't I will post diagnostics.